ServerAlias field has disappeared

I’m running Virtualmin GPL 3.91 on CentOS 5.8 x86_64 on a couple of systems. It appears that a recent update has removed the field (whose label I don’t recall) from Virtualmin -> Services -> Configure Website -> Networking and Addresses which permitted the specification of a list of domains to be placed in the Apache ServerAlias directive. I know that I can still edit that directive in the config file manually, but it was somewhat more convenient to do it the old way. Has that field moved elsewhere (I’ve looked but not found it), or is there another recommended way of managing ServerAlias? I typically use it to specify a temporary dev alias from a domain on a sometimes-different Virtualmin system which doesn’t necessarily share DNS with this one.

Howdy,

Well, a common way to manage ServerAliases for a given VirtualHost would be to go into Create Virtual Server, click “Alias Server”, and add an alias that way.

Adding a Virtual Server Alias will add an Apache ServerAlias directive.

Would that do what you’re after?

-Eric

The setting in question is named “Alternate virtual server names”, and for me, also in Virtualmin 3.91 it still appears on the “Networking and Addresses” page.

Are you sure you’re looking in the right place? :slight_smile:

Is the field also missing when you access the Apache module directly from Webmin? I wouldn’t know why the Webmin developers should remove the field, since it’s a pure Webmin thing and unrelated to Virtualmin.

Adding a Virtual Server Alias will add an Apache ServerAlias directive. Would that do what you're after?

I was aware of the option, but hadn’t tried it. It looked as though it might be doing more than I needed. I did just play around with it, though, and found that if I uncheck “Setup DNS zone” and leave “Setup website for domain” checked, it’s close enough. It adds two new ServerAlias directives:

ServerAlias www.original-domain.com existing-alias.com ServerAlias new-alias.com ServerAlias www.new-alias.com

I’d prefer that it not add the www.* form, but I can live with it. It claims to be creating a new home directory, but (happily) doesn’t actually do so. It’s a good enough workaround for me; thanks.

The setting in question is named "Alternate virtual server names"

That’s the one!

Are you sure you're looking in the right place? :)

Sadly, yes.

Is the field also missing when you access the Apache module directly from Webmin?

Yes, I’d checked there already. FWIW, I’m running Webmin 1.585.

While creating an alias domain is fine as a workaround, if anyone knows how to re-enable the “Alternate virtual server names” field, please speak up.

You can prevent the www. from being created by editing the Server Templates, section BIND DNS Domain. There’s checkboxes for the subdomains that get auto-created.

As for the disappearing edit box: If it really was there and is gone now, that sounds like a Webmin bug to me.

To check this again: When you go to “Webmin / Servers / Apache Webserver”, tab “Existing virtual hosts”, and you select one that has an IP address shown, what does the header line of the edit page show? It should be like “Virtual Server Options – For example.com:80”.

In “Networking and Addresses” there, you should have fields, from left to right and top to bottom, “Lookup hostnames”, “Do RFC1413 user lookups”, “Server admin email address”, “Alternate virtual server names”, “Server hostname”, “Use hostname supplied by browser”.

If you’re seeing something else, please provide some screenshots if possible.

The Webmin version in Virtualmin’s Ubuntu repositories is 1.580 by the way. So, @Eric, maybe a bug was introduced in some newer version that hasn’t been rolled out to Ubuntu yet?

You can prevent the www. from being created by editing the Server Templates, section BIND DNS Domain. There's checkboxes for the subdomains that get auto-created.

Yes, though I normally want the ‘www.*’ variant when creating a new server, as opposed to a temporary alias. I suppose I could create an alias template as a workaround, though it’s not much of an issue, really.

It should be like "Virtual Server Options -- For example.com:80".

It is.

If you're seeing something else, please provide some screenshots if possible.

Attached. The “Server hostname” field is missing as well. This is consistent across all domains on four CentOS servers.

Okay this looks very much like a Webmin bug to me. If Eric doesn’t pick up this post here, you might want to file a bug report issue.

Maybe the options in question have been moved to a different screen; if you can’t find them anywhere, go for the bug report.

btw I have exactly the same missing fields on my box with VM Pro 3.91 Pro/centos 5.8/Webmin version 1.585

Yeah, it’s possible that the options were removed from the newer Webmin for some reason.

I suspect if fields were missing that it was done intentionally, but I’m not sure where those would be now.

I’d suggest filing a support request using the Support link above, and in that request, explain which options are missing from which screen, and see if there’s an alternate way of doing all that now.

-Eric

I can’t see a reason why those specific two fields should have been removed, except their functionality was moved elsewhere. If not: Bugreport. :wink:

done
https://www.virtualmin.com/node/21968

Thanks; I’ll follow that, too.

Any progress on this?