server now on a mail blacklist (postfix sending out spam)

Is there a way to lock down postfix to send only from emails from the local server. I can see several spam emails stuck in the mailqueue an example below:
note the FROM field “” is not one of our email addresses.

From “Marilu Fabrice”
To “tangelamartinson5538”
Date Fri, 10 Feb 2017 05:16:54 +0000

with this being the bounce back in the queue:

I’m sorry to have to inform you that your message could not
be delivered to one or more recipients. It’s attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.
The mail system mail for loops back to myself

I have run a rootkit scanner and clamav nothing comes up so i am strugling to find out where the problem lies. If I can lock down the POSTfix sending then this will help, Just to note the server doesn’t need to be set up to receive email it only sends mail from a few wordpress sites from webforms (which have captchas)

It could be you are running an email open relay, you have enabled DNS recursive queries, CMS/theme/plugin are hacked, hacked server or account, wrong configuration for postfix, or all together.

hi, it could be as Diabolico - specially, I would change right a way passwords - for that account. I would be keen to think that password for that account was compromised due to as Diabolico mentioned or simply password was too easy to guess. I had that problem on my friends virtualmin. as soon as I changed password to ‘normal’ one (16 characters mixed with capitals and low letters and numbers) and deployed fail2ban all spam did gone away. good luck.