Server not finding Virtualmin 6 update

My production server is not finding the update to Virtualmin 6 currently on 5.99. I have a test server elsewhere which updated when it first was released. I can access from the production server no problem and all other previous updates worked fine.

I have triple checked the repo conf etc etc.

This is on CentOS 6.9 which is the same as the test server.

Check /etc/yum.repos.d

You’ve perhaps disabled or removed the virtualmin-old repo.

Hi Joe

The only repo for virtualmin is virtualmin.repo, are you saying that there should be another named virtualmin-old ?

This is the content of the repo

[virtualmin] name=RHEL/CentOS/Scientific $releasever - $basearch - Virtualmin #baseurl=$releasever/$basearch/ baseurl=$releasever/$basearch/ enabled=1 gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-virtualmin gpgcheck=1

name=Virtualmin Distribution Neutral Packages

On my test server the 2 lines which are commented out and the one below are reversed which I tried on the production server but made no difference.

If I ping from my production server I get I have a feeling this is no longer the correct IP so has it been updated as it seems like a propagation issue with the ISP where the server is located. If that is the case what is the correct IP and how can I force it, I seem to remember something about adding this to the resolv.conf file but not sure and or the correct sytnax.

Yeah, you’re hitting the old software server, which is no longer being updated and will be taken offline in a few weeks/months (whenever I get to Dallas to pull the server out of the rack and retire it, after the rest of our Cloudmin repos are removed from it).

Check your /etc/hosts file for old information. If you ever manually added an address for

The new addresses are: and

But, you should not hardcode them anywhere. Figure out how to get resolution working via DNS. These addresses are only semi-permanent, and will change periodically; the new repo servers are cloud servers, and we’ll spin them up and down as needed. The IPs are reserved, but if we ever have problems with the hosting provider or whatever, we can/will spin them down and spin new ones up on other IPs without notice.

Hi Joe

Yes it had been hardcoded in the hosts file which I had forgotten about because of an issue when first setting up the server.

Thanks as always.