Server moved - now not functioning properly

My server had been hosted by LiquidSolutions and for the most part, I was quite pleased with their service. LiquidSolutions was purchased and the owner, ClouldShards, shut down the server that hosted my VPS. Though ClouldShards did send a notice, for some reason, I did not receive it. So, instead of having time to prepare, I had to ask them at the 11th hour to move my VPS.

The VPS was moved and I updated the DNS records about 12 hours ago. (I keep the DNS records on NameCheap and not the VPS itself). I also requested that they create a rDNS record for my server. Though the new server exists, it is not behaving in the same manner as the old one. The specific issues I noticed are as follows:

1: The VPS control panel does not show the proper OS, disk space, or memory size. ‘System Information’ from VirtualMin does.

2: I logged into the system via SSH. From the command line, all network-centric commands time out. For example, I tried ‘host’, and the system responded “;; connection timed out; trying next origin;; connection timed out; no servers could be reached”. Basically, it cannot resolve any addresses. (It has been suggested that having localhost in /etc/resolv.conf can cause this problem, but that is not the case here.)

3: When I enter the IP address into my browser, instead of getting to my home page, I am directed to my webmail login.

4: Sending email (smtp from Outlook) seems to be a bit slower. (I am referring to the time it takes the message to leave the Outlook Outbox. Since the server cannot resolve names, outbound messages are no going any place…) Also, logging in via TeraTerm is very slow.

My guess is that the underlying hardware may be somewhat different and that is the root cause of the problem. I truly do not want to have to rebuild the system - either from scratch or backups. Can someone suggest some steps to resolve these problems other than rebuilding?

This is a bit hard to evaluate, since as you said yourself a number of potential hardware-related issues might be at play. I’d suggest to ask your hoster what the hardware specs of the old and new server are, and how many customers are/were sharing the server.

  1. This is quite probably a matter concerning your hoster - you might want to ask them why the old panel showed the correct data and the new one doesn’t.

  2. My best guess is that the hoster-assigned nameserver IP addresses have changed when your VPS was moved. You’d want to ask the hoster for the proper new ones and update them either in /etc/resolv.conf or /etc/network/interfaces or similar, depending on distro.

  3. Do you mean webmail from your hoster, or your own webmail? In the latter case, what webmail on what domain would that be?

  4. This can have a number of reasons, maybe a delay due to DNS timeouts. We should resolve 1-3 first before looking into this.

In general, you should be able to continue using your VPS without rebuilding, that’s normally what a virtual system is for. :slight_smile: It should be possible to move it between hypervisor instances without having to do big changes (aside from IP addresses and stuff).


Thanks for the answers - will send a couple of support requests per your suggestions immediately.

Two follow-up comments:

2: The distro is CentOS 6.5, 64 bit. The nameservers listed in /etc/resolve.conf are google public server, specifically and (There is no /etc/network on my system.)

3: I mean my own email. When I enter into the address bar, I am directed to which is the login page for Horde. I am wondering if this is perhaps related to issue 2 - that there is some name resolution that is supposed to happen (with local ‘aliases’) that is not being properly handled.

This issue is extremely problematic - I reply on email for my (consulting) business. If the hoster does not provide helpful information in a reasonable period of time, is there anyone in this (VirtualMin) community that I could hire to help?

Okay, let us know what your hoster replies!

Yeah that’s right, the files are named differently on CentOS. Eric might know more, he’s the CentOS encyclopedia here (I use Ubuntu myself). :wink:

But, if you’ve been using the Google nameservers before and after the move, and now they cannot be reached, it is possible that your hoster is blocking outgoing DNS requests to “foreign” servers on your new host for some reason. You can test that with the “dig” command, where you can explicitly state which nameserver to query.

If it turns out that e.g. a “dig @” times out, you might want to shoot another support request your hoster’s way. :slight_smile:

I’m a bit confused… In your first post, you said that you tried to enter the IP address in the browser. It does not really look like an error to me that “” should direct you to “” . :slight_smile:

Can you re-iterate what exactly you entered in the browser, which domain you were expecting to see and what you got instead?


#2 - address resolving

Per your suggestion, I tried dig:

[root@admin ~]# dig @

; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.23.rc1.el6_5.1 <<>> @
;; global options: +cmd
;; connection timed out; no servers could be reached
[root@admin ~]#

I provided this information to my hoster (who claims that this issue has been escalated to his network team).

#3 - website

I host two websites on my server - my Drupal site and Horde email. Drupal is installed in public_html and Horde is installed in public_html/webmail. Up until the server move, when I would enter into a browser, the Drupal site would be presented. To get to the Horde site, I would enter, or, into the browser. This is the desired functionality.

After the move, regardless of the subdomain entered into the address bar, i.e.,,,, etc.; the page that is presented is the Horde login page. The Horde login page is also presented if I enter the IP address into the address bar. The URL shown in the address bar is, but the page is really

About 3:

Do you have two virtual hosts in your Apache? The construct is a bit odd, having a separate site in a sub-folder of another site AND having a subdomain pointing to it. :slight_smile:

You could instead put the webmail site in a completely separate virtual server, like a sub-server of your main domain that will reside in /home/DOMAIN/domains/SUBDOMAIN/public_html. Then you have a clean distinction how to reach which site.


I suspect the problem is that my language is not precise. To the best of my knowledge, my Apache configuration is quite vanilla.

I may have accidentally discovered the cause of the problem: When I visited webmin->Servers->Apache Webserver to answer your question, I saw that the address listed for my server was the IP address before the move. I poked around and found that the IP address is obtained via DNS query, so it occurred to me that now that the DNS record changes have fully propagated, I should reboot. Upon so doing, there was a indicator that the primary IP address had changed, should the system be updated. I clicked yes, VirtualMin did its magic, and everything is now back the way it should be.

Thanks for pointing me in the right direction!

Regarding #2 above: Tech support resolved this - they reported, “there was a stray route lingering for some reason in your container.” This issue seems to have also been the cause of #4 as responsiveness is now as expected.

p.s. This forum should offer some type of recognition system. Locutus has provided help to me, and others, many times and should be recognized for his knowledge and generosity.

Thanks for your recognition, it’s appreciated! :slight_smile:

About the IP address: Yeah that’s right, it needs/needed to be changed in Apache (and BIND if you hosted the zones on your server); I was assuming you had already done that.

I’d be surprised though that the IP address for your system is retrieved via DNS. Do you maybe mean DHCP? In any case, yeah, as soon as the interface IP address changes, Virtualmin will notice that and offer you to update the addresses in your virtual servers.


Again, my understanding/language may be imprecise. When I clicked on ‘Networking and Addresses’ under Apache Sever, I saw the following: Lookup hostnames No Yes Lookup twice Default. This is what made me think that the system was trying to look up its own address.

Whether my understanding is right or wrong, it doesn’t matter - I did the right thing! :slight_smile: (And even a broken clock is right twice per day.)