serious errors after 1.401 update

i am having some serious errors after updating and i cant figure out how to roll back to the older one. when i try to switch to a servers admin i get an error. also i get errors when i push the back button on the browser. it tells me that there is no page like what i was just at that exists. everything is broken. is there any way i can roll back the update or will there be a fix to this very soon.

please someone help me. Thanks for reading
any impute is appreciated.

You haven’t told us what the error is. “serious errors” isn’t very descriptive, nor doe it help me figure out what’s going wrong on your system. :wink:

Rolling back is possible, but probably not necessary. Webmin is probably just in need of a restart. Shut down Webmin, kill all of the miniserv.pl processes to make sure it’s actually down, and then start Webmin back up.

Ok here is a list of errors.

1.) when you click on Administration options and switch to servers admin. for a virtual host i get

Error
Existing session not found!

also when i click on the button that says return to previous page it sends me to a blank page.

2.) If i go to view the disk usage of a virtual host i get this message.

Security Warning	

Warning! Webmin has detected that the program https://www.domain.com:10000/right.cgi?open=system&auto=status&open=updates&dom=1200277134313487 was linked to from an unknown URL, which appears to be outside the Webmin server. This may be an attempt to trick your server into executing a dangerous command.
If your browser does not send the Referer header needed, you can turn off this check as follows :

Login to Webmin normally.
Go to the Webmin Configuration module.
Click on the Trusted Referrers icon.
Check the Trust links from unknown referrers box, and click Save.
Alternately, you can configure Webmin to allow links from unknown referers by :

Login as root, and edit the /etc/webmin/config file.
Find the line referers_none=1 and change it to referers_none=0.
Save the file.

and this also happens on lots of other buttons when i hit back on my browser when before i could hit back and there was no problem.

those are the major problems that i am having in almost every page. and the feature to log in as another user like the one i posted above is a major importance to test accounts.

there is no problem with the server itself and i dont get too much traffic in to Webmin but i need to get it fixed.

can you help me please. can i roll back the update and reinstall 1.401.

all your help is appreciated. thanks

o and i forgot to mention i did try to restart webmin. with the miniserve.pl killed.

sorry but it didn’t work.

thanks again!

hanks for the fix.

but i was wondering if there is any way to roll back the update to the vesion before it?

thanks again.

The “referrer” errors is because your browser is set to not send those. You can’t do that with webmin/virtualmin as those referrers are required. So enable them.

well thank you everyone for the help. i fixed the problem but i noticed that on the webmin website that the Webmin version is at 1.400 but virtualmin is calling for 1.401 same for the Usermin. why is that???

1.400 had a bug in the BIND module. 1.401 fixed it. We are the developers of Webmin, too, you know…we can do that sort of thing when it effects customers. :wink:

thanks Joe now i understand more clearly. just one thing i dont know if this means anything to you but i did try the Webmin 1.400 update instead of 1.401 and the problem of the user switching is gone, but in 1.401 there is the error. it seems like the little change in the line of code is the fix. that line of code that gets changed to fix the problem doesn’t cause any security holes. since when i was editing it it did look like those lines were important.
let me know. funny its too bad i am the only one having this problem as so it seems! : )

for issue 1 and this fix is coming from Jamie which solved the issue on my server

edit the file /usr/libexec/webmin/miniserv.pl
find the hash_session_id function starting on line 4565, and replace with :

sub hash_session_id
{
local ($sid) = @_;
return $sid;
}

then run /etc/webmin/restart

for issue 2
I have the same errors and warnings but i didn’t attempt to disable trusted refferes as switching to users is more effective.