I want to use sendmail as my mail server, However when I click on the start button It does not respond. Postfix is somehow set as the mail server but when I click on it to stop it won’t stop. I vaguely remember a post earlier addressing this issue but I can’t find it. Help would be appreciated.

Pete i have the same issue did you ever find a cure??

It’s covered in the FAQ:

And in this response to Bill’s own query about the same problem here:

(Just wanting to make sure folks can find the answer if they’re searching for it in the future.)

Note that this problem isn’t related to Sendmail, at all, it’s just you’re less likely to have found the FAQ since Sendmail, unlike Postfix, won’t fight against you using @ in the username.


What distro are you using?

And, are you fairly certain Sendmail is installed now?

Have a good one,

I am running CENTOS 5 on my server and yes I am sure it is installed. It was working for a while during testing. I am not sure why it stopped. This is the last thing I need to fix before deployment.


Okay, CentOS has a nifty little configurator for switching between the various MTA’s. I’m wondering if CentOS is currently setup for running Postfix by default.

Right now, if I run this on my CentOS box:

ls -l /etc/alternatives/mta

It shows that Postfix is currently active by it’s link to the Postfix binary:

lrwxrwxrwx 1 root root 26 May 17 2007 /etc/alternatives/mta -> /usr/sbin/sendmail.postfix

If I want to switch to Sendmail, I can then run:


Which is part of the system-switch-mail package (and not installed by default). It’ll present you with the option of switching to Postfix / Sendmail, at which point you can choose Sendmail.

Does that by chance fix up your issue?

When I run that command I get /etc/alternatives/mta -> /usr/sbin/sendmail.postfix which indicates that postfix is running as the mail server. When I run the second command I get no such file or directory. Which means the switch utility is not installed. Shouldn’t I be able to correct this problem from within VA/WA??


> Shouldn’t I be able to correct this problem from within VA/WA??

Perhaps, though I’m unfortunately not familiar with how to do that. Maybe someone who’s familiar with how to do that could answer that question… or when Joe and Jamie return from the conference they’re at this evening, perhaps one of them will pipe up with how to go about that within Virtualmin.

What I can offer is that if you were to run this command:

yum install system-switch-mail

You could install the switch utility and use it to tell CentOS to use Sendmail rather than Postfix. But again, as you said, there may very well be a way within Virtualmin to accomplish that.

i also can’t provide with an adequate solution but if centos and virtualmin use Postfix by default then there must be a good reason. Perhaps the reasons they have, might make you reconsider using sendmail?

Postfix is installed by default with VM install script.

The work around for this is to remove postfix then install sendmail AFTER the install of VM. If you add any domains before you do this sendmail aliases and addresses will not be ported over to sendmail.

I installed the system-switch-mail utility and used that to change from postfix to sendmail. If someone figures out how to avoid this problem or how to change it from within Webmin/Virtualmin please let me know. Thanks to all who helped-dirtybird.

I installed the system-switch-mail utility and used that to change from postfix to sendmail. If someone figures out how to avoid this problem

This is a perfectly valid approach–nothing wrong with it at all. system-switch-mail does make alternatives a little easier to use. If you have any trouble getting Virtualmin spinning with Sendmail, let us know. It’s not our default, but we support it fully–just like Postfix. I just don’t know as much about it, as it’s been years since I’ve managed a Sendmail server. But lots of Sendmail users are roaming the halls around here, making ghoulish noises now and then. :wink:

At Scott’s noisy insistence, we’re working to make the Postfix part of the installation a little less pushy (Postfix will always be the default, but it will probably become possible to skip it during installation).

I am still having problems getting rid of postfix after running the VM Pro install script. Did you get a chance to address this issue?