Sendmail Problem

I run into a problem today that is strange.

I receive Mail to my Mail-Domain. I can send mail from my Mail Domain.

But when I try to send mail out of the virtualmin environment e.g. Re-Send Welcome Mail, Send Updated e-Mail Infos and so on â

Hey David,

The first google result I found for that error was someone who already had Postfix running. If you installed Virtualmin Professional, it will have installed and fired up Postfix for you. To switch back to Sendmail, you’ll need to use the alternatives command to change the system default MTA, and then stop postfix and set it not to start on boot.

If this is not the case, I’m not sure. Sendmail is not my strongest area, and it’s been a while since I’ve maintained a Sendmail server (though we do support the use of Sendmail for folks who prefer it to Postfix, or need some feature or third party milter for Sendmail).

Typo of course, I am switching from Postfix to sendmail.

and so much for hiding my domain names???

No biggie… Just trying to get email up and running.

Alan

Hey Alan,

Switching mail servers after you’ve already created domains is a bit tricky. The two mail servers use a different format for virtual address table files, and there is no automated mechanism for converting them. It’s not overly complex, and since you only have two domains it should be a big problem, unless you have a lot of user accounts as well.

There was a thread about going the opposite direction a week or two ago here:

http://www.virtualmin.com/forums/message-view?message_id=50612#50612

The problem is the same, just in reverse.

Oh, yeah, if you haven’t actually done anything with your domains (install scripts, setup a bunch of users, add content, whatever) you could just delete them and recreate them with the new mail server. This should create the appropriate entries.

I removed both domains, and then set up only one of them with one email user.
I have the same results.
I also tried sending an email directly from the system via
sendmail -s test asawyer13nospam@yahoo.com
test
test
ctrl d

but it appears to just be sitting the outbound que.

I don’t believe it’s a firewall issue.
Any ideas?
Joe, if you want to get into the system, just let me know via email asawyer@nospam.asboinc.com (remove nospam.)

Alan

Dovecot is running now.
smtp port on firewall should be open.

This is what was in maillog. I restarted system just to see if that helped:

Jul 23 15:12:24 ip-208-109-104-119 dovecot: Dovecot starting up
Jul 23 15:12:30 ip-208-109-104-119 sendmail[[2372]]: alias database /etc/aliases rebuilt by root
Jul 23 15:12:30 ip-208-109-104-119 sendmail[[2372]]: /etc/aliases: 78 aliases, longest 10 bytes, 802 bytes total
Jul 23 15:12:30 ip-208-109-104-119 sendmail[[2377]]: starting daemon (8.13.1): SMTP+queueing@01:00:00
Jul 23 15:12:30 ip-208-109-104-119 sm-msp-queue[[2385]]: starting daemon (8.13.1): queueing@01:00:00

There was nothing else in the log, however the email I sent to yahoo.com is still trying to be sent

doing a ps -ef|grep mail gives me

[[root@ip-208-109-104-119 log]]# ps -ef|grep mail
root 2377 1 0 15:12 ? 00:00:00 sendmail: accepting connections
root 2378 2377 0 15:12 ? 00:00:00 sendmail: ./k6NLME5n032353 mx3.mail.yahoo.com.: user open
smmsp 2385 1 0 15:12 ? 00:00:00 sendmail: Queue runner@01:00:00 for /var/spool/clientmqueue

Alan

I tried sending another message from linux to my email asawyer@asboinc.com and this is what it added to the log

Jul 23 15:22:28 ip-208-109-104-119 sendmail[[3267]]: k6NMMQ0t003267: from=root, size=50, class=0, nrcpts=1, msgid=xxxxxxx.k6NMMQ0t003267@ip-208-109-104-119.ip.secureserver.net, relay=root@localhost
Jul 23 15:22:28 ip-208-109-104-119 sendmail[[3268]]: k6NMMSV9003268: from=root@ip-208-109-104-119.ip.secureserver.net, size=400, class=0, nrcpts=1, msgid=xxxxxxx.k6NMMQ0t003267@ip-208-109-104-119.ip.secureserver.net>, proto=ESMTP, daemon=Daemon0, relay=ip-208-109-104-119.ip.secureserver.net [[127.0.0.1]]
Jul 23 15:22:28 ip-208-109-104-119 sendmail[[3267]]: k6NMMQ0t003267: to=asawyer@asboinc.com, ctladdr=root (0/0), delay=00:00:02, xdelay=00:00:00, mailer=relay, pri=30050, relay=[[127.0.0.1]] [[127.0.0.1]], dsn=2.0.0, stat=Sent (k6NMMSV9003268 Message accepted for delivery)

I had to remove a little text and replace with xxxxxxx because the post wouldn’t allow it.

However I haven’t received the email yet, and according to webmin, there are now 2 messages in the que.

Alan

Now a connection timed out message, but the 208.109.97.18 is valid and I’ve been getting mail there all day.
Alan

Jul 23 15:24:28 ip-208-109-104-119 sendmail[[3270]]: k6NMMSV9003268: to=asawyer@a sboinc.com, ctladdr=root@ip-208-109-104-119.ip.secureserver.net (0/0), delay= 00:02:00, xdelay=00:02:00, mailer=esmtp, pri=120400, relay=asboinc.com. [[208.109 .97.18]], dsn=4.0.0, stat=Deferred: Connection timed out with asboinc.com.

I decided to try to start fresh so I removed the 2 emails that were sitting in my servers outbox and then I sent a message from my laptop which is connected via cox.net to my server’s email account alan@yourticketto.com

This is what log shows:
Jul 23 16:08:50 ip-208-109-104-119 sendmail[[4067]]: k6NN8oCu004067: from=asawyer@asboinc.com, size=2383, class=0, nrcpts=1, msgid=001201c6aeac$e8b98c80$ba2ca580$@com, proto=SMTP, daemon=Daemon0, relay=fed1rmmtao01.cox.net [[68.230.241.38]]
Jul 23 16:08:52 ip-208-109-104-119 sendmail[[4068]]: k6NN8oCu004067: to=alan@yourticketto.com, delay=00:00:02, xdelay=00:00:01, mailer=local, pri=32611, dsn=2.0.0, stat=Sent

Which sure looks to me as being correct and that it worked, but I don’t see anything in /home/yourticketto/homes/alan/mail
The directory is empty… webmin also doesn’t show any email in the system for user alan

Alan

however virtualmin shows 9 messages so they’ve been going thru. Looks like I was looking in the wrong directory.

Now on to trying to receive email, and then to see if mail sent from the server gets out to me.

Outlook is just saying that it’s can’t connect

Log onto incoming mail server (POP3): Outlook cannot connect to your incoming (POP3) e-mail server. If you continue to receive this message, contact your server administrator or Internet service provider (ISP).

Alan

okay it was a login name problem.
In the past when connecting to sendmail (at least I think they were sendmail) servers that had been set up with Plesk the username was name@domain.com
Now it’s name.domain
Made that change and it works.

Now I need to see if I can send emails from the server out to me.

Alan

Hey Alan,

What do you get when you connect via telnet to port 110? It ought to look a bit like this:

[[joe@delilah ~]]$ telnet virtualmin.com 110
Trying 70.86.4.238…
Connected to virtualmin.com (70.86.4.238).
Escape character is ‘^]]’.
+OK dovecot ready.

If it doesn’t, the firewall might be blocking the port. Otherwise, I’m not sure why Outlook would give that particular error–if Dovecot is running, it ought to at least be able to connect. Maybe Dovecot hasn’t been configured to accept POP3 connections? This should have happened during installation, but if you’re making significant changes from the Virtualmin defaults some other configurations may have gotten broken or overwritten in the process. Check /etc/dovecot.conf to be sure the protocols directive has pop3 in the list.

Everything appears to work except if I send an email directly from the server. It shows a timeout on the email server I’m trying to send to.
I need to get it fixed in the next couple of days so I will continue to work on it, but may need more help later if I can’t get it figured out.
Thanks,
Alan

Hey Alan,

You can choose "user@domain" as a setting in Virtualmin server templates. Works fine for sendmail, it gets dicy in postfix.