Sendmail not configuring

Dear All,

Virtualmin does not want to configure.

It tells me:

[code:1]The status of your system is being checked to ensure that all enabled features are available, that the mail server is properly configured, and that quotas are active …

  BIND DNS server is installed, and the system is configured to use it.

  The Sendmail mail server does not appear to be installed on your system, or has not yet been set up properly in Webmin's Sendmail Mail Server module. If you are running a different mail server, select it on the module configuration page.

… your system is not ready for use by Virtualmin.


I goto server >> Sendmail Mail Server and it tells me

Module Config
Sendmail Mail Server
Sendmail version 8.14.2 Search Docs…

Your sendmail config file does not appear to be for the latest sendmail version. Webmin only supports versions 8.8 and above.[/code:1]

How can I get Virtualmin to configure?
Many thanks
Andrew<br><br>Post edited by: jinxster, at: 2009/01/05 02:18

Ok I progressed a little bit.

When I start sendmail I get

* Starting Mail Transport Agent (MTA) sendmail 554 5.0.0 No local mailer defined 554 5.0.0 QueueDirectory (Q) option must be set [ OK ]


Is it your intention to run Sendmail rather than Postfix? Postfix is the Virtualmin default, and comes setup pretty well :slight_smile:

I’m not much of a Sendmail guy, but poking around on Google for that error shows some messages about needing to set a line like this:

O QueueDirectory=/var/spool/mqueue

(You’ll need to make sure that directory is correct)

In the /etc/mail/ file (you can probably also set that from within Webmin’s Sendmail Module).

Recompiling Apache rarely seems desirable :slight_smile:

That makes updates in the future a pain, and Virtualmin even provides their own Apache packages in the hopes of preventing you from having to re-compile it.

If you wish to recompile, searching for “Ubuntu recompile Apache” on Google brings up a few resources that should help (and the Debian instructions are remarkably similar to Ubuntu); but perhaps there’s a way to avoid that?

What problem are you trying to solve?

Where can I find virtualmin’s source for ubuntu? (ie what can I put in sources.list?)

And then is it simply: apt-get install httpd?

The problem is the suexec is pointing to the wrong directory. It needs to point to /home and not /var/www.

Apparently you need to recompile to do this. I found this: which worked for another guy.

The last guy obviously did the recompile and finished installing virtualmin, then after he updated he could put in a link from /var/www to /home. The problem is to get past virtualmin install. This inherantly suggests there could be “bugs” in his particular installation in future, unless virtualmin is just strict on a setting which doesn’t really mean anything.

Anyhow, I got the recompile, after correcting about 6 dependancy packages im stuck on

dpkg-buildpackage: warning: Failed to sign .changes file -bash: dpkg-buildpackage:: command not found

If you got a place for me to apt-get a /home version please help. Thanks

Okay, it sounds like you simply have the distro’s version of Apache rather than Virtualmin’s.

While recompiling is a solution, it’s the more difficult way of going about it :slight_smile:

You can see the various Apache packages you have installed by running this:

dpkg -l ‘apache*’

The Virtualmin packages have a version number ending in "vm", such as "2.2.8-11vm".

So the goal would be to replace the current Apache packages with those in the Virtualmin repository (they’re near identical, but with the correct suexec path).

If you didn’t install Virtualmin using the script, you’ll want to make sure you have the Virtualmin repository added to the /etc/apt/sources.list file.

Apart from the default za.archive repositories, I only have

deb sarge contrib

What is the virtualmin repository?

Thanks for your help andreychek!

Hrm, I’m beginning to suspect you may not have installed with the script. For future reference, the install script makes life a ton easier, and automatically handles most setup tasks such as this :slight_smile:

The repository you’d use depends on what distro/version you’re using, and whether you’re using the GPL or Pro version of Virtualmin.

However, the GPL repository is here if that helps get you started:

You mentioned something about Ubuntu; if you’re using Ubuntu 8.04, I believe the Virtualmin repository entry would be:

deb virtualmin-hardy main

No I didnt use

I read someone that required a clean install and rhe manual way didnt.

I had a few other panels on here, and the server is a long way away so reinstalling was out the question.

Now it tells me

apt-get install apache2=2.2.8-11vm Reading package lists... Done Building dependency tree Reading state information... Done E: Version '2.2.8-11vm' for 'apache2' was not found

Is there another version number? How can I find it?

I feel like I made the 100km marathon but i cant do the last 1km.

Yeah, it looks like you have the package name right; did you run "apt-get update" after adding the Virtualmin repostory to the sources.list file?

Aah yes, that struck me in my sleep.

Ok virtualmin is up and running. (Finally!)

Ok a big thanks to andreychek.

Ok I successfully found a "few" problems.

In my file I had put in the line:


Ok I successfully found a "few" problems.

In my file I had put in the line: