Sendmail Configuration problem :(

Hi all,

I installed Virtualmin on Webmin.
It said the installation was successfull. The "Virtualmin" link was added to the "Servers" menu.

When I click on the "Re-check and refresh configuration" button in the Virtualmin page, there occurs an error. Below is the output:

"The status of your system is being checked to ensure that all enabled features are available, that the mail server is properly configured, and that quotas are active …

BIND DNS server is installed.

No address mapping (virtusers) file was found in your Sendmail configuration. Your may need to add the appropriate feature your Sendmail M4 and re-build the configuration.

… your system is not ready for use by Virtualmin."

The error is about Sendmail configuration. I had installed Sendmail but I do not know what to do with its configuration.

I really want to use Virtualmin, but I can’t :frowning:

Can you please help me?


Do a:

yum install sendmail

it will fix it…

you didn’t mention your OS so assuming it’s not YUMable then, in webmin, go to Seandmail. Click the sendmail M4 configuration. It will show you what’s configured but go to the bottom and ADD NEW ENTRY TYPE and choose FEATURE in the window chooose VIRTUSER_TABLE and CREATE. THen choose to REBUILD the configuration and it will take care of you. :slight_smile:

Or, if you aren’t particularly tied to Sendmail for some reason, you could use Postfix. It’s easier to configure. (Though, to be fair to sendmail, it’s actually easy once you understand it’s cryptic configuration syntax and language.) :wink:

I resemble that remark !!! :slight_smile:

Actually the webmin Sendmail M4 config module is a Godsend for making the configuration easy.

It’s just trying to figure out from what you need, bring along 6 cryptographic translators :wink:

Hey Dan,

Speaking of translating hard topics…Jamie and I are in the midst of wiki-fying our books. That’ll be about 1000 pages of reasonably good quality documentation in an easily searchable, nicely indexed, online and free format. And because it’s a wiki, anyone will be able to contribute.

It’s a huge (huge, huge, HUGE!) job, but it’s always bugged me that Jamie’s book was only available in print and PDF. At least mine was Google-able. But HTML, print, and PDF all have some serious flaws for documenting an Open Source project that develops as fast as Webmin has been during this past year. We expect to announce it sometime in the next few days (I wrote a conversion script to convert from Jamie’s .doc files to wiki, but it seems to have dropped tables and some other vital data, so we’re kind of plodding along cleaning things up a bit…and I haven’t even started on converting my book yet).

You guys here at will be the first to know when we launch the docs for Webmin wiki site.


Thanks :wink:

that is just totally awesome!!! :slight_smile:

I am having the same problem as the original Poster except that I now get the following error when I try to rebuild:

Failed to build configuration :

m4:/etc/mail/ ERROR: end of file in string

I know very little (nothing actually) about sendmail.

Post line 18 here.

Also with sendmail mc format be sure that you use a TAB space and NOT normal 8 spaces or the M4 will choke on it.

ok i had the same problem on ubuntu 7.0.4
I ran sendmailconfig from a command line and got an error that said I need FEATURE() above MAILER() so I edited my M4 Configuration file by hand and ran sendmailconfig again and it worked.

this is the bottom of my M4 Configuration file

Other dnl #
Feature FEATURE(virtusertable')dnl Other dnl # Default Mailer setup Other MAILER_DEFINITIONS Mailer MAILER(local’)dnl
Mailer MAILER(`smtp’)dnl
Other dnl #

After feature add, root command ‘sendmailconfig’. This will fix it.