Sendmail config issue - outgoing addresses file

Centos 5.6 - Latest Webmin with Virtualmin module and Virtualmin theme. Sendmail (inc -cf)


I’ve installed the virtualmin module but can’t get past the Sendmail problem I’m having. The message is:

“No outgoing addresses (generics) file was found in your Sendmail configuration. Your may need to add the appropriate feature your Sendmail M4 and re-build the configuration, or disable this feature in Virtualmin’s module config page.”

In Sendmail configuration I’ve added to the Outgoing Domains, and Relay Domains. If I click on Outoing Dmains Generics it states the following:

“Your sendmail configuration does not have the outgoing address mapping (generics) feature enabled. Click here to setup sendmail features.”

If I click on the “here” url, it takes me to “Sendmail M4 Configuration” page. I’ve added:

FEATURE(genericstable',GENERICS_DOMAIN_FILE (`/etc/mail/generics-domains’)’)

just above the MAILER lines. I’ve restarted Sendmail, but still no joy.

Am I missing something really obvious? Sorry about the long post.

BTW - There are no domains yet added to the server. I need to resinstall 2 vps, but can’t do this until virtualmin is running.

Thanks in advance for any help.



Is there any particular reason you’re looking to use Sendmail rather than the default Postfix? Most folks around here, including myself, are far more knowledgeable with Postfix, and it’s simpler to configure :slight_smile:

I honestly don’t know what to suggest for how to fix that… but I might suggest that, unless your a Sendmail guru, that you may want to still with the default of Postfix – it’s configured to work right out of the box when you run the Virtualmin installer, and if you do happen to run into issues, more folks will be able to lend a hand :slight_smile:


Howdy Eric,

My dedicated server came with Sendmail and Webmin. I installed Virtualmin as a module.

I’ve just removed Sendmail and it’s dependency sendmail-cf.

I’ve installed postfix with yum install postfix -y, the result is : postfix.i386 2:2.3.3-2.2.el5_6 .

I’ve fixed some of the problems as they were highlighted to me, but it now states:

“The Suexec command on your system is configured to only run scripts under /var/www, but the Virtualmin base directory is /home. CGI and PHP scripts run as domain owners will not be executed.”

I’ve seen a post elsewhere that suggests “to disable “Automatic SuExec directive” under VirtualMin’s System Settings -> Server Template.” - Would this be ok, or is there a better solution?

Thanks for your fast response by the way!


Aha, I see… that may be the longer and harder way of installing Virtualmin :slight_smile:

Are you using a fairly new Linux installation?

If so, you might find the automated to be a nice and simple way to get Virtualmin up and running. It’ll handle pulling in all the various dependencies, and getting everything configured.

The problem there is that if you have any live data on your server (ie, if it’s not a fresh Linux installation), it could break existing sites or email addresses.

The automated script is available in the Download link above.

If you’d like to configure things manually, using the Virtualmin module – you can do that, but it’s a more involved setup. The details of how to do that are available here:

The document above will describe how to handle the suexec issue (amongst other things).


Many thanks for your help.

I’ll have to go with the apache modifications.