Sending mail through SMTP server via Gmail

Alright, so I’ve come here as a last resort hoping to find that last bit of help I need to solve this. I’ve spent the last two days scouring for answers without actually getting anything direct. First off, I’m an amateur at best, and this is all new territory for me when trying to understand these things. I’ll try my best to describe my issue.

On my current virtual server, I’m using Centos 7 with virtualmin installed. I’ve set up the email accounts just fine, and they work well. (I can login using roundcube to send and receive mail just fine as well).

As a convenience to the people who would be using those email accounts, I was trying to do a “send mail as:” through gmail so that they could reply to email coming it as those addresses (as opposed to their own personal gmail).

I keep getting the “domain name not found” error when using I’ve double checked to make sure I have the correct username and password (which I do), and tried a couple things to see if anything has worked. Here’s what I’ve done so far, and the fields Gmail is asking for.

SMTP Server:

Username: _________

Password: __________

Port: 25, 465, 587 (as expected)

Secured connection using SSL

Secured connection using TLS

  • uncommented appropriate lines in the file
  • created SSL cert and copied it over
  • restarted servers after editing (of course)
  • using the login information with port 465 using SSL and and it gave me a “too slow to respond” error, so that was different
  • tested connection using “telnet (and any of the three ports)” but I don’t think I’m doing it right since it’s giving me “unable to resolve host”
    - if that is what’s supposed to be coming back, I guess those ports aren’t open? In which case, how do I open them since nothing stood out in the master and files in postfix?
  • I’ve seen where you might have to add some lines to allow google to connect via SMTP? Not sure on that.

Anyway, that’s what I have so far. It feels like I’m just missing something small in order to get it to work. Any help would be much appreciated.

I was wondering …
Did you find a solution for this?