Secondary DNS nameservers and subdomains

Hi,

I’m using Virtualmin 3.68 Pro to manage several sites (example.com, etc). Two of those sites have a whole bunch of sub-servers accessible by sub-domains (sub.example.com).

The server is running BIND as it’s main nameserver. Since you must have 2, I bought secondary nameserver services from DynDNS.com http://www.dyndns.com/services/dns/secdns/.

I’ve configured it so that their servers are allowed to do the transfer so this is working fine for our main domains but it doesn’t seem to pick-up any of the sub-domains/sub-servers. Access to those sub-servers is a toss-up depending on which nameserver is interrogated. If the main one that Virtualmin is running is asked, no problem. If it’s the secondary one, it replies that the sub-site doesn’t exist; problem.

Now, I’m no expert on BIND (or nameservers, or DNS for that matter) so I may be misunderstanding something. As far as I can tell, when creating a new sub-server, Virtualmin creates a new zone for it in the BIND configuration.

I think this is where the problem is coming from. I think the secondary nameserver is just picking up what’s in the main domain zone (example.com) and not seeing what’s in all the others (sub.example.com, subby.example.com, etc.) so it doesn’t know about those.

I tried to consolidate all the sub-domains in the main domain’s zone but what I tried didn’t work so I’m really hesitant since I’m afraid of screwing up something.

Am I on the right track?

Thanks for the help!

I’m guessing you’re on the right track with consolidating in a single zone file. Virtualmin can do that automatically for sub-servers now (at least, I’m pretty sure that was one of the bugfixes in 3.68, though it might actually be in 3.69…hard to keep up). It’s a configuration option in the Server Templates BIND section labeled “Add sub-domain DNS records to parent domain?”

Oh, and you’ll have to disable and re-enable DNS for the sub-servers to get this change to happen, I think.

Thanks Joe, yeah, I found the option in the templates and it is currently set to “Yes”. So I think I’m good on that front.

How do I disable and re-enable DNS for the sub-servers? I hunted around a bit and couldn’t find how.

Thanks again.

Never mind. I found it minutes after hitting send (of course).

For other newbies that might find this thread in the future, it’s in “Edit Virtual Servers”, “Enabled features” and finally “DNS domain enabled?”.

Yessss! It worked.

I’m so lucky that that feature got implemented. I didn’t relish the prospect of dealing with all that BIND config!

One thing though. It doesn’t impact me but it might be troublesome for someone else so I figured I should report it:

We have two domain names that our site uses: example.com and example.net. They are arranged like this:

[ul]
[li]example.com[/li]
[li][ul][li]example.net (alias of example.com)[/li][/ul][/li]
[li]sub.example.com (sub-server of example.com)[/li]
[li][ul][li]sub.example.net (alias of sub.example.com)[/li][/ul][/li]
[/ul]… and many many other sub-servers
The new feature puts the .com sub-domains in the .com zone but the .net sub-domains always get put in their own zone. This means that my secondary nameserver never sees the sub-domains for the .net domain.

Now, we always use the .com domain so this isn’t a big deal for us. (The .net name is legacy.) But I’m assuming it might cause problems for somebody else.

Hi, Ipsa!
Can you please post a step-by-step tutorial on what you did to have domains and subdomains working on your server? I want to make sure I understood everything sicne I’m trying to make my subdomains work and I can’t: http://www.virtualmin.com/forums/limit/10/limitstart/10/webmin/re%3Asubdomains-not-working-again.html
Thank you!