Script stops running after around 3 minutes

I am trying to run a WordPress plugin which imports a bunch of entries from a CSV file and converts them to WordPress posts. I have already taken care of setting the following in the script:

ini_set(‘memory_limit’, -1);

ini_set(‘max_execution_time’, 0);

Even then the script stops after around 3 minutes.

I have already tried adding the following to /etc/apache2/mods-available/fcgid.conf:

FcgidBusyTimeout 604800

FcgidIdleTimeout 999999999

FcgidMaxRequestsPerProcess 999999999

MaxRequestsPerProcess 999999999

IdleTimeout 999999999999999

FcgidMaxRequestsPerProcess 999999999

FcgidIOTimeout 999999999

That didn’t help either.

Anyone here has an idea what’s required to make sure a script run indefinitely?

PS: PHP script execution mode is set to FCGId


You may also want to look in Server Configuration -> Website Options, and there set “Maximum PHP script run time” to a large value.


Hi Eric,

I have set that to unlimited already.

Any idea what else it can be?

What if you set it to a large number, rather than Unlimited – does that make a difference?



Unfortunately it doesn’t. I created a small script that sleeps every second and then writes to a file. I created it to run for 15 minutes. It ran fine without any problem.

Does MySQL have a timeout limit?