SCP only restriction not working and a funny behaviour when locking a FTP-user to his folder not working and


I wanted to allow /force users to use SCP instead of FTP. But
when I edit users > Other user permitions to SCP only, it doesn’t work - the user continues to access therough FTP and refusing SCP.

Thanks in avance if anyone can help.



I had another issue, concerning FTP Directory restrictions but I solved it - There is another way - via webmin > Servers > Proftpd Server > Files and Directorie > Limit users directories.
Anyhow, there is some kind of funny behaviour that I’d like to understand if could be solved:
When I try to lock-in the Limits and Validation > FTP Directory restrictions, to “Only Server”, it updates configs and applies. but in reality it doesn’t: user continues to acces entiire server files and if when I enter again into imits and Validation > FTP Directory restrictions, it shows selected “All virtual servers”.


Hi. I solve the SCP - by default, ProFTPd has already SFTP.
Also removed the hash from DefaultRoot on proftpd.conf.

So, this is solved in a workaroundish way. But perhap virtualmin team can take a look at these behaviours.

Hi, how did you “solve the SCP”? What do you mean by “by default, ProFTPd has already SFTP”

I have this issue. Using scponly still gives the user FTP. I just cant see how to disable FTP and actually give scponly.


Unless you disable FTP entirely, allowing any access usually allows FTP access.

I suppose you could add the user to the /etc/ftpusers file…

Just in case others see this post, this post discusses the same and has my reply.