Scheduled Tar Backup with no compression still uses gzip

I am using Virtualmin GPL and have been using scheduled backups for many years.
Recently I have tried to switch the backup from tar.gz to uncompresed tar so that my bup (git-like rolling hash compression) backup archive strategy can be employed to save data transfer costs and time.

It seems as thought the file names are correct, but the backups are still gzipped.

I have tested this on a empty dummy test server and experienced the same problem. Is this is bug?

My System Details are as follows: Ubuntu Linux 18.04.5 Webmin version 1.973 Virtualmin version 6.16 Authentic theme version 19.73

Virtualmin probably needs some type of container like tar to put the files to backup and restore. I’m not sure how bup works but you could write a script to uncompress your backups in the folder you have them set to and then let bup do what you want it to do.

@harlequin516 why not bash script written into your perfection by you or someone else executing with Cron job with or even outside of virtualmin? simple

The “Backup compression format” help shows "You can also use un-compressed tar format backups, which may be useful if you want a speedy backup, or if you are writing to tape. "

But when (uncompressed) tar is selected it is still using compression as a tar.gz format while naming the file as a tar.

I have a after backup command script that runs to do the transfer to my bup server. The problem is that, the generated tar files are not as described in the options in the vuirtualmin UI. I could just uncompress them as an additional step before uploading them. But…

It still seems like a bug. I tried looking at the code, but I am no expert with Perl. I bet someone would find this bug easily if they knew perl.