Scheduled Backup on FTP Server

Hi Guys
I’m trying to setup “Virtual Servers Scheduled Backup” as well as “Webmin Backup Configuration” to a remote FTP server of mine.
Parameters are all corrects, I can actually access without issues through FTP Client (CuteFTP in active and passive mode), web-browser (pasting ftp address), in file explorer, and I tried also to connect though SSH Client shell using ftp and put command as explained here (
However I keep getting this error “STOR /volume(sdb1)/Server/Configuration/25-08-2016 failed : Permission denied.” -_-

ARRRRRRRGGGG What the hell I’m doing wrong?

From all the test done above appears that the issue should not be tight to the ftp server, maybe there is some kind of limitation on webmin configuration.
I really do not know.

Anyone can give me some suggestion?


What happens if you log in using your desktop FTP software, and upload a file into that directory – are you able to do that?

It sounds like you’re seeing a directory permissions issue of some sort, that the FTP user logging in may not have permissions to write to that particular location.


Hi Eric

Thanks for your answer, I have already tried that and it works. I can upload a file in the directory as well I can place put command to upload a file from my ssh client shell. Moreover doing an ls through my ssh shell I get following:

drwxrwxrwx 1 0 0 4096 Aug 07 11:12 volume(sda1)

drwxrwxrwx 1 0 0 8192 Aug 25 10:26 volume(sdb1)

Hi Eric

Can you please suggest me some kind of log file so to see in details where is the problems, to what is tight? Is it possible that the problem depend from passive or active ftp mode? When I have done the PUT through ssh client shell it was done automatically in passive mode.
I would like to sort out this issue one time forever, so any kind of clue or suggestion would be really appreciated.

Thanks in advanced.