Scheduled Backup Issue

Hi,

I am running Virtualmin 4.01 GPL on CentOS 6.4 x64 (OpenVZ VPS)
I have created two backup schedules to sync all my virtual servers to a second VPS, first one is full backup and the second is incremental.

I has two issues

First one:
I don’t want to backup the Apache logs, removing the check from “Include logs directory” did not work, i had to remove the check from “Include homes directory” to stop Apache logs from backups.

Second one:
If i run any of the scheduled backups manually it works fine, but if i leave it to run on the scheduled time, it does backup the Apache logs, even though its not supposed to be backed up.

Any help?

Interesting issue! Does the problem occur during full and incremental runs? How are you transferring the backups, do you use SSH or FTP? Which “Backup format” are you using (single file, one file per server etc.)? I’m trying to reproduce the behavior right now.

I can confirm this problem!

I’m doing a test backup to a local directory (/tmp/backup-test) of a domain on my experimental VM, in “one file per server” format, backup level “full”.

First issue, when I select “backup only these features:”, select all features, and turn ON the “include logs”, when I save and re-enter the edit screen, the “include logs” checkbox is turned OFF again.

Second issue, like moweis described, even when I save the schedule with “also logs” turned off, the logs do still get backed up, in the “.backup/DOMAIN_web_(a|e)log” files.

I’m assuming that the “include logs” checkbox is not processed properly, i.e. not adjusted when entering the edit screen, and its state always assumed “checked” when Save Schedule is clicked.

Both incremental and full backups.
I am transferring the backup via SSH
One file per server.
Delete old backups => Never
Checked: Create destination directory, Only send email on failure

Backup All virtual servers , all plans, include sub-servers
No DNS, MySQL in the backup

Virtualmin settings to also backup:
Virtualmin configuration
Server templates and plans

My backups are now more than a gigabyte in size instead of a 100k or so.