Schedule backup not working

It work on almost a month after clean installed.

It just doesn’t working days before.

  1. no update has patched on server
  2. manual backup to the same FTP works fine
  3. can’t find error on var/log/cron

is there anything i should go to check?

There are currently 4 backups running, and the system-wide limit is 3

how can i disable the limit?


Well, there shouldn’t normally be that many backups running at once… that may mean something isn’t configured correctly.

You’d probably want to check all the scheduled backups, and make sure only one is running at a time.

However, you can configure the backup limit in System Settings -> Virtualmin Config, and there, you can set “Maximum concurrent backups”.


1 Like

so the best practice should be, 1 full backup per 1 cron job?

4 sites 4 different schedule backup?


Oh, you can perform a backup of all domains during one cron job.

However, the error that you’re receiving suggests that 4 cron jobs are running at the same time.

That usually means that either multiple backup cron jobs were accidentally scheduled to run at the same time, or the backups that are running are taking way longer to run than expected.


thank you so much!