SASL trouble

I was getting a permission denied error in mail.log from saslauthd when i tried to enable ‘server requires authentication’ in MS Outlook. So I chmod 775 /var/spool/postfix/var/run/saslauthd and adduser postfix sasl according to the help forum stuff I could find. Now I can enable ‘server requires authentication’, but the email still sends without this enabled. It now sends mail either way, checked or unchecked. I am pretty sure that this would set my server up to be used as a spam server, if you could send without a login required. How do I shut off access to smtp without a login?

Well, regardless of whether you check "server requires authentication" – you should be able to send an email to a user on your server.

Any system on the Net can do that, that aspect shouldn’t require an authenticated user.

The trick is whether you can send an email to someone on another server.

So, you could try emailing a gmail or yahoo account – and I suspect that will only work when you’re authenticated.
-Eric