SASL authenticates some users but not others?

Hi all,

First post so please be gentle :slight_smile: I’m running Webmin v1.470 on Fedora 10 (I realise it’s not supported but I have a feeling this problem isn’t a Fedora-specific one) and I’m having some trouble with migrated cPanel domains and Postfix/SASL authentication for SMTP AUTH.

Some mailboxes authenticate fine. Others don’t. And I can’t find a common factor, other than it seems to be all or nothing with regards to domains. So everything@example.com will be fine, but everything@example2.com won’t be.

All the users are listed in /etc/shadow and I’ve tried with known passwords/usernames. My config files are attached if they’re of any use.

I’ve also tried using testsaslauthd from a prompt to check, eg:

[user@server ~]# testsaslauthd -u info -p qwerty123 -r example.com -s smtp
0: NO "authentication failed"

but other ones are fine. All the migrated domains were imported into Webmin in exactly the same way.

Hope the above is enough information to go on - please let me know if you need any further info!

Thanks in advance,

Rich.

Files attached: Postfix main.cf, /etc/pam.d/smtp and /usr/lib64/sasl2/smtp.conf