S3 backup failing with no output

Hi, I have just set up a scheduled backup to an S3 bucket. The backup fails every time but does not produce any output as to why. I get the message:

Starting backup of 2 domains to directory/%Y-%m-%d–%H-%M-%S in Amazon S3 bucket mybucketname …

But then immediately I get:

Backup failed! See the progress output above for the reason why.

But there is no progress output.

If I change the schedule to backup locally it works fine. I have the AWS CLI installed and I am able to copy files to the bucket via the command line with no problem.

How can I troubleshoot the issue here?

Operating system: CentOS Linux
OS version: 8.2.2004

Hi,

This issue has to be fixed with the latest, upstream s3-lib.pl update. Give it a try.

Besides, make sure that you have awscli package installed.

Hi Ilia, I grabbed that file and placed it at /usr/libexec/webmin/virtual-server (first renaming my existing file to s3-lib.pl.old). Firstly can you confirm that’s what you intended me to do?

I ran my backup script again, and just as before, it failed with no output whatsoever as to what the error may be.

I can confirm I have the awscli installed, and I can manually copy files to the bucket from the command line with no problem.

I grabbed that file and placed it at /usr/libexec/webmin/virtual-server (first renaming my existing file to s3-lib.pl.old).

You would have to restart Webmin after updating these lib files.

I would suggest checking on logs in /var/webmin.

@JamieCameron Jamie, if I remember correctly, we fixed this issue just recently, where there was no error printed with S3 backups?

I don’t remember that - do you know which ticket or commit it was?

OK, so I ran:
/etc/init.d/webmin stop
and
/etc/init.d/webmin start
Should that be sufficient to get Webmin to use the new s3-lib.pl file?

I ran the backup again, and as before, it errors without any output, except to direct me to the output for the reason for failure.

In /var/webmin I checked the file miniserv.error but there is nothing in there related to the failure - is that the file into which S3 errors are written?

@Ilia or @JamieCameron do I need to do a reboot to get Webmin to use the updated s3-lib.pl file? Restarting Webmin doesn’t appear to have changed anything - backups are still failing with no output.

Not a reboot, but you will need to run /etc/webmin/restart

Thanks @JamieCameron for confirming, I have done that and run the scheduled backup again, it still fails with no output as to why, so the new s3-lib.pl file does not appear to make any difference in my case. Any idea how I can troubleshoot this any further?