RoundCube upgrade error (no mysql module)

I’m trying to upgrade RoundCube from 1.4.11 to 1.5 using Install Scripts feature.

When I click on Upgrade Selected Scripts — Upgrade Now, Virtualmin shows an error:

Upgrading RoundCube to version 1.5.0 …
PHP module mysql is required …
Enabling module in PHP configuration …
… done
Module is not available even after installation!

Mysql module is there and enabled, I don’t know why Virtualmin suddenly thinks it’s missing. Upgrading to previous Roundcube releases worked flawlessly.

Debian 10.11
Virtualmin 6.17-3
Webmin 1.981
Latest PHP 7.4

I can confirm that there is an issue after this script uprade. My upgrade went through without any error but when I login to Roundcube there is no mail in my Inbox, but states that there is an ‘Internal Server Error’.

i have same problem

on debian you can install intl extension
i think
apt install php-intl

I’m not sure it is related to my issue, but at least now I know some have installed Roundcube 1.5 without this error message.

Good catch. Assume this will be on CentOs 8 as well and we need to do dnf install php-intl. Thanks for posting

i don’t know, but i had this error also on a debian 10 and resolve with
apt install php-intl

thank you too :slight_smile:

Installing php-intl didn’t change anything for me, but seems that Virtualmin developers improved their installation method for Roundcube and now it works: Roundcube 1.5 - php-intl is now a required PHP library · Issue #325 · virtualmin/virtualmin-gpl · GitHub They also install php-intl automatically.

Tried the upgrade again and now it went throough flawlessly!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.