Roundcube issues with defaultaddress book [Solved]

Hi Teams,

I have being facing an odd issue since last week…

I client complained that he no longer has the ability the add/edit entries in his address book, using roundcube.

This issue is very new for me, and since last Friday I’m trying to figure out what could happened and got nowhere.

Every test I’ve done on my testing server faces the same issue, with either version off Roundcube available thru virtualmin install scripts.

Server has a multiple domains, and no ‘central’ instance for Roundcube. Simple install the Roundcube on the virtual servers home dir, with it’s own MySQL DB…

The issue:

Every time we try to edit/add entries to the default installed address book on Roundcube we get stuck on an " Loading …" page or simply on the same page, and unable to switch back, to the mail tab for instance. We have to hit the reload button and them we can switch.

The same happens on the settings tab.

I’ve tried an extensive, AFAIK, Google search and tried almost any similar solution… changing skins, alter time switches, etc … and yes, looking at the logs, and so fat nothing. Not even an error on the logs … frustrating as Hell.a

I couldn’t find any valuable clue what might be the problem. … :((

Server is a CentOS 6.6 x86_64, all patched up and virtualmin also.

Any ideas what might be causing this issue ??!!

Hoping you guys can shine some light on this, I’ll keep searching …

Best regards and Season Greetings.



After several hours, I decided to create a new virtualmin server on my own virtual environment …
And since it worked there i started to eliminating issues, and end up with my Apache config, regarding SSL Poodle issue …

The offending line was:

‘Header always set X-Frame-Options DENY’

as opposed to the correct one:

‘Header always set X-Frame-Options DENY<<<<’

So to everyone having some similar issue, this was my issue and solution.

Regards and Season Greetings to ALL.