Roundcube Display name & Viewing emails error

I have two concerns I would like help with.

  1. Under settings, identities…it shows the default display names as first.last.tld

I know you can manually change the display name here in the users own email account, but is there a way to get it to change the default format for all accounts in the background?

I would like it to take the “Real Name” shown in Virtualmin under the “Edit Mailbox” screen. Often “First Last” or “Department/Group”

  1. Every email I open shows a screen saying “The website cannot display the page, HTTP 500,…etc”

Why are the html formatted emails being blocked? I checked that HTML is enabled.

Is it something to do with HTTP vs HTTPS? I tried using https://domain.tld/roundcube and got the same error, but http works fine.

HTTPS vs HTTP may be another topic altogether but I’m finding its messing alot of things up.

Any one know why Roundtree defaults to view HTML but won’t display any HTML emails? I have to turn off “Display HTML” under the roundtree setting to see the messages.

I still don’t know how to get it to use the User Description for the Display name instead of the user account either. Anyone?

I found related info to this on the Cpanel forum but its 3 years old and i can’t seem to figure out how to apply the fix with Virualmin