Reverse for Dedicated IP - Not working.

Hi there.

I’m trying to config for more than 2 days and can’t get it working.
I have 3 websites with his own Dedicated IPs.
The PTR record rDNS is oks on the provider.

I have followed this and now I have the e-mails sent by IP but it send helo with instead of

When I do the tests, I’m getting SMTP greeting errors because the SMTP Banner send the hostname of the server instead of the domain IP.

SMTP banner All banner greetings comply with SMTP specified format. | 220 ESMTP Postfix (Debian/GNU)

Here is the error, it sending the hostname of the server instead of send hostname for this ip.

SMTP greeting | WARNING: The hostname in the SMTP greeting does not match the reverse DNS (PTR) record for your mail server. This probably won’t cause any harm, but may be a technical violation of RFC5321

On cPanel servers, it does automatic rule over the file:

And the file contents shows like /etc/hosts
This file have

I’m getting tired trying to config this. For 2 days and can’t.
Can someone help me with this?

Thank you!

Well, no way, backing to cPanel.

Okay, good luck with cPanel, if you can’t even wait for 2 hours (on a Sunday) for someone to respond.

Finished the tests. cPanel cannot to it too.

Back to Virtualmin again!

smtp inet n - n - - smtpd -o smtpd_sasl_auth_enable=yes

Change it to: inet n - n - - smtpd -o smtpd_sasl_auth_enable=yes inet n - n - - smtpd -o

And now it works. But need to manual edit the smtp greetings on virtualmin.

I’m gonna try this:

And I’ll back here to post the results.

Thank you!

Here some posts and tutorials that I’m trying:

Well, I just don’t know how I got this working.

I’m getting now green status on smtp banner and smtp greetings.
But I don’t know how, because the smtp banner shows the dedicated IP of this domain but the reverse is of the main IP shared.

SMTP Banner | 220 ESMTP Postfix (Debian/GNU)

SMTP Greetings |

But my PTR rDNS records on the service provider are:

Anyway, when i got to mxtools or dnsstuff, it is getting gree (OKS) on all options.
I believe will keep this config then. If I’m getting green status, it shows working oks?

I also tried to add this line on (commented this first line and added the second line)

#smtp inet n - - - - smtpd -o smtpd_sasl_auth_enable=yes inet n - - - - smtpd -o smtpd_sasl_auth_enable=yes -o -o

But with this, I’m getting error on greetings.