Restoring to new server

My server crashed and I’m trying to restore my Virtualmin backup to a new server. I think I was using ver 3.48 but I’m not sure. I have tried 3.41, 3.48, and 3.62 all have returned the error of “No selected features in backup” for all servers in the backup. I tried multiple feature selections including restore all features and then only selected features. No luck. Any Ideas?

Don’t keep trying different versions. That’s just gonna waste your time and cause frustration. :wink:

Are you sure the backup file(s) is a Virtualmin domain backup, rather than a filesystem dump or some other form of backup? Virtualmin is very specific about what it will restore–it doesn’t know anything about Webmin’s other backup modules. (And it’ll also generate a file called “virtualmin.tar.gz” that is not a domain backup–it just contains Virtualmin configuration data, unrelated to any domains. Restoration of that file is done differently.)

If it is a Virtualmin backup, then we’ll need to see one of the backups that’s exhibiting this problem. You might want to file a ticket and attach one of your backups (after switching the ticket to private). Or you can file a ticket and email Jamie or me a copy, or make it available on a website somewhere. Obviously, smaller is better. :wink:

Your right. I took a closer look and found it was a tar image of my entire /home directory. I can not find any tar.gz virtualmin backup files. I extracted the tar file into a seperate area so I atleaste have the /home files. Now without the server backups I will have to recreate each virtual server by hand. I could have sworn that I was backing up the servers. They should have been in the /home area and would have been included in the tar file.

Thanks

Found them. They were on a partition that was not mounted yet. :slight_smile:

Thank you for your help. It got me thinking in the right direction.

Getting error messages containing:

Wrote only 8192 of 10240 bytes

Wrote only 3584 of 10240 bytes
tar: Skipping to next header

Cannot write: No space left on device
tar: Skipping to next header

Cannot open: No such file or directory

Error exit delayed from previous errors

There is plenty of space on the HD. I was able to extract a 4GB tar file with no problem. The virtualmin backup is only 768MB. /tmp only has 600MB of free space but the I get the error message pretty quick and it was able to extract the 4GB tar file earlier. The server only has 256MB Ram at the moment. Any Ideas? Would a updated virtualmin help? Currently trying to use 3.48 as I believe this was the version I was using.

Found the problem. ./tmp was to small. I reconfigured webmin to use a temp folder in a much larger partition. The old temp folder was located in a partition that was to small and prevented virtualmin from being able to decompress the backup file. Can’t restore what you can’t read. Extracting my /home dir backup tar file must not have required a temp dir.