Restored Subdomain Server Can't Be Found Error

Hi all,

I am trying to build a new machine. I did a few practice restores before I started and everything seemed okay.

But now, even though the rest of the restore worked, one domain’s subdomain returns a “server can’t be found error” to my browser.

httpd.conf seems right. Virtuamin shows everything as I would expect.

named.conf and the associated config files seem okay - and a remote tracert returns the right address.

The files really do exist, in the path that virtualmin is expeecting under the apache settings.

There are no obvious errors in any if the logs that I can identify as such, the subdomain is simply not being found.

Does anyone have a suggestion as to where I might start looking for the problem?

Thanks for your time!


What does “not being found” mean? You’d need to provide some further info here.

On what machine are you trying to fetch the web page? Does the hostname resolve? Is the IP correct? Does the IP reply to Ping? Can Apache on the IP be contacted (telnet <ip> 80)? What is the exact error message and what gives that message? What’s in the logs for BIND and Apache?

Getting a “server not found” error often suggests a DNS issue.

One possible cause for that is if you tried going to the server when it was offline, it’s possible your system has cached the fact that it’s not there. Trying again a bit later might show it working just fine.

Barring that – where do the nameservers for this particular domain point, are they pointed at your Virtualmin server? If your nameservers are using a third party’s DNS, you may want to verify that the sub-domain you’re using is setup in that third party’s DNS tools.


You’re right.

There seemed to have been an issue with the DNS slaves in the cluster. Possibly because I had listed both “this server” and “” as members of the cluster, the zone file got corrupted. Even so, the domain name still resolved to the proper IP address correctly from mulitple geographic locations.

BUT… it could have been because of some propagation delays.

I manually edited the bind files and it seems to be okay at this time.

Thanks everyone.