Restore failed

I wanted to restore 18 virtual servers, but one gave me this:

Restore failed : No section found for mod_fcgid directives

Since it was a subserver, it also caused the other subservers of the same primary server not to be restored. So, how can i fix it? The other ones would have been restored correctly.

Thanks and best

Update: it was not just one server, currently there are two of them. The other virtual servers i brought over from the same machine didn’t have that problem. how can i fix that? Two of those virtual servers are pretty important to me, because of the email server.

Any idea is truly appreciated.

I thought, i could figure it out if i set those two servers on the old one for using fcgid. It claimed, that i would need suexec, which i enabled and then i tried to change from mod_php to fcgid, including running as domain owner.

When i did that i got that error message:

Missing or invalid website documents sub-directory

So what? i need those two pages. …
Thanks and best

Have you tried to restore just the Mail/FTP users and mail aliases and other setting that you might need but not the files etc ? After that you can unpack the backup and rsync or copy the actual files back to the virtual server.