Restore Failed due to File exists

Trying to restore backup to a backup server and get this error:

Extracting TAR file of home directory …
… TAR failed!

/bin/tar: ./public_html/mail/doc/ReleaseNotes: Cannot open: File exists
/bin/tar: Error exit delayed from previous errors

Restoring Virtualmin settings (Module configuration, Server templates, Reseller accounts, New mailbox email messages, Custom fields, links and shells, Third-party script installers, Third-party content styles, Scheduled Virtualmin backups, FTP directory restrictions) …

I did see a bug report on something similar to this; but it had no other information of use.
I have been restoring to this drive for a long time; not sure why it will not work anymore.
I chose everything to restore.
What can I do to solve this?

Hmm, who is the owner of that Virtual Server (ie, what is the username)?

And, what do you see if you type:

ls -ld $HOME/public_html/mail/doc/

(where $HOME is the path to that users home directory)

The Account Name for each domain; I tried to restore them individually and it didn’t matter; the folder in question is a Squirrel mail folder; which I installed from a VM script; I reset all the permissions on the folder to insure they have read/write permissions; that didn’t help so I deleted the ReleaseNotes folder; that did the trick; but still doesn’t explain why it is having trouble with this folder; it had 755 for the folder and files in it.

It doesn’t hurt to delete all the ReleaseNotes folders; but it doesn’t seem I should have to is all; but that’s just me.