Restore doesn't include e-mail

Hi all.

I’m trying to move websites from one VM to another (both running Virtualmin,) and everything but e-mail seems to be going over fine. That is, public_html and accounts are transferred, but inbox contents are not.

Anybody have a solution for this problem?

Best Regards,

Jesper Nielsen


What kind of server do you have – is it a dedicated server, or a VPS? If it’s a VPS, do you know what type it is?

Also, what does “free -m” show?

And if you go into the Maildir directory for those users, do you see their emails within the “new” and “cur” directories"? Or are those directories empty?



Both old and new installs are Ubuntu 12.04 LTS based VM’s. Both VM’s are based on KVM and hosted with Digital Ocean.

free -m returns:

total used free shared buffers cached
Mem: 994 763 231 0 17 216
-/+ buffers/cache: 529 464
Swap: 0 0 0

Maildir folders are empty on the new VM. The weird thing is, if I extract the backup archives the Maildirs are right there for me to view. The new server just won’t import it for some reason.


I’m in the process of migrating from one server to another, and the latest backup/restore didn’t bring the emails across. the home//Maildirs are there after the restore, but no emails.

As per Yezper’s experience, if I extract the tar.gz then the emails are present.

I have restored a server earlier in the year (between the same boxes) and everything seems to have worked correctly that time.

I am wondering if a recent Webmin upgrade has introduced this problem.


We haven’t been able to reproduce this issue on our own systems, even using a backup from someone else who had reported this same issue.

So the issue doesn’t appear to be with the backup specifically.

Would it be possible for one of us (the Virtualmin staff) to log into your system as root, setup some debugging in the restore process, and run through a restore?

If so, could you open a new Support Request using the “support” link above, mark it as private, and include your root login details there, along with the path to a backup that we can restore?



I tried to migrate my webmin/virtualmin server also from my Virtual Server (I suppose its Virtuozzo) to my new Virtual Server (KVM, 4GB RAM & 240GB HD only for Webmin!, the Backup itself is just about 6GB). And I tried the backup module on the web surface an i tried it via console like its mentioned in ( Both ways created the domains, the email Addresses but all the mailboxes are empty.

I moved from my OpenVZ Virtual Server some months ago the same way to the actual Virtual Server (I still suppose its Virtuozzo) and it worked without any problems…

I just moved about 10 domains over, and I noticed after they were restored that their mailboxes were completely empty!!!

Exact same symptoms as above, I selected to backup everything on the original server, and restore all on the destination.

Looks like the restore script is completely ignoring the users home directories …

Both servers are running CentOS 6, Virtualmin 4.04 GPL

I decided to just export all mails to a PST file from Outlook (I don’t have many mail accounts on the server,) and then import them to the new server, so I hope that one of the other people having the same issue can give you this access.


Sorry, I should have posted my server details in my original comment:

FROM: CentOS Linux 5.3, Virtualmin version 4.04.gpl GPL

TO: CentOS Linux 6.5, Virtualmin version 4.04.gpl GPL

Using a FULL backup and restore.

@ Eric (andreychek) “could you open a new Support Request using the “support” link above, mark it as private, and include your root login details there, along with the path to a backup that we can restore?”

I see Ip86 has raised a ticket for this [Restore doesn’t restore users home directories] and I’m adding a comment to that.

Okay, Jamie was able to identify the problem that causes this issue.

There will be a fix posted for the issue, but the workaround in the meantime is to use the command line to perform the restore. That can be done with a command like the following:

virtualmin restore-domain --source /backup/to/backup.tar.gz --all-domains --all-features

Hi Eric,

Many thanks for the update and work around.


Thank you very much for the workaround… i was looking for the error while backing up … an did not take a look at the restore process …


Has there already been a fix for this issue or should I still use this workaround?
My server is currently very unstable (DNS seems to be failing every couple of hours, only solution is a reboot. This happened after a successful attack). And I need to backup and restore my users asap.



That issue should be fixed now… if you run into any problems doing that though, let us know!


Great, I’ll try it tonight when the new server has arrived.

like a charm :slight_smile:

Not sure if related or different, but when I migrate a CPanel backup with about 1Gb total mail over 20 accounts, all accounts are empty in Usermin.

I can see that /home/account/Maildir/ includes all the email, but I guess Usermin is using the default mail path at /home/account/domains/

Is this a bug?

Sounds like you’re seeing a different issue here… there was a problem back in February where data from user accounts wasn’t being included in a backup file. It sounds like you’re seeing a problem with restoring a cPanel backup though.

Could you open up a new Forum thread, and in there, describe the problem you’re seeing, and let us know the output of these two commands:

ls -la /home/account/Maildir/ ls -la /home/account/Maildir/