Restore Backup Failing with no specifics

I got a daily backup (for last 5 days) going into Amazon S3. Files are created, everything seems ok, I thought I was “covered” with those backups.

Now I want to restore a server into a new computer (same OS and virtualmin version), So I select “RESTORE BACKUP”, place my bucket/Path … press the “SHOW WHAT WILL BE RESTORED” button. Virtualmin takes some time “working” (30 seconds or so) …

Only to get the “Restore failed : The specified source does not contain any domains, or is not a Virtualmin backup”.

All hell broke loose for me.

I tried, in the bucket and path, to change the path right into the .info file, or the .dom file or the tar.gz file of the server I want restored, and I always get the same error. I also tried to place a more general path, like bucket/computer-folder (just looking into the 5 days directories), same error. I think I tried everything. It just won’t work.

Any tips or help, appreciated.


If you look in Backup and Restore -> Backup Logs, do your recent backups show up as completing okay? Or do you see any errors listed there?


You might want to unpack the backup archive manually and see if that works, and if it contains a proper Virtualmin backup structure. In the archive there should be directories like so:

/.backup /etc /fcgi-bin /logs /public_html /tmp

.backup contains a number of files like so:

DOMAIN_dns DOMAIN_logrotate DOMAIN_mail and so on

You might also try pointing the restore function to the directory that contains the backup files, instead of the files directly, or the other way round, depending on what you tried so far.