restore backup doesnt restore all users or any mail

Hi,
I have just installed a new server and put webmin with the virtualmin module on it.
I have setup a couple of test sites and all appears to be working ok

(system details below)
I am trying to restore a backup from an older server (running the latest webmin/virtualmin).
The original virtual server has 2 users (1 primary account and 1 additional mail account)
Its backup size is 159MB (most of that is mail) i upload the backup file to the new server and ask it to restore the backup, it complains that DNS is not installed but is in the back (which is fine as im not using dns on this new box) there are no other errors reported, and the restore appears to run fine.
Only problems are :

  1. There is only 1 user added for this virtual server (the primary 1)
  2. The entire virtual server only takes up 32K!

Now I admit there maybe something that i have missed int he setup of this new server, but all the webmin config pages appear to be happy, and the virtualmin page says its happy with the config (re-check and refresh).
But I dont understand why im not getting any errors.

Please, could anyone point me in the direction to look?

thanks

Matt

Operating system Debian Linux 6.0
Webmin version 1.610
Time on system Fri Jan 4 01:45:04 2013
Kernel and CPU Linux 2.6.32-5-openvz-amd64 on i686
Processor information Intel® Celeron® CPU E1200 @ 1.60GHz, 2 cores
System uptime 16 days, 7 hours, 01 minutes
Running processes 18
CPU load averages 0.00 (1 min) 0.00 (5 mins) 0.00 (15 mins)
CPU usage 0% user, 0% kernel, 0% IO, 100% idle
Real memory 485.03 MB total, 127.68 MB used
Local disk space 20 GB total, 4.93 GB used
webmin 1.610
virtualmin gpl latest module from webmin.com
Apache : 2.2.16
Postfix : 2.7.1

Howdy,

If you go into Edit Users, does it show that user as being part of the Virtual Server?

What you’re describing almost sounds like the it doesn’t think that Virtual Server has that user in it.

Or, it’s also possible that the feature to backup email users wasn’t enabled.

You may want to check that in the backup options, in the “Features and settings” section, that the “Mail/FTP users and mail aliases” option is selected.

-Eric