[Resolved] Software.virtualmin.com might get weird for a little while

Howdy all,

I’m refactoring build scripts to accommodate automatically building and publishing packages directly from git without (much) human involvement. This requires significant changes to how the /vm/6 repos are generated and minor changes to how the /vm/7 repos are generated. Either or both might get broken for a little while today (obviously, I’m trying not to break anything, but last time I tried it, the /vm/6 repos lost group support and had metadata mismatches because of changes in createrepo_c vs the older createrepo that we’ve historically used).

There’s no need to do anything. There won’t be any updates while it’s being worked on, so as long as you’re already up to date, you probably won’t notice anything amiss even if I break something.

I’ll follow up here when the work is done, probably a couple of hours from now.



I believe the worst is over. I was able to update a system using /vm/6 yum repos, so I think I didn’t break anything major (if anything).

I may do some more breaking tomorrow when I start pushing package updates automatically, but we’ll cross that bridge when we come to it.

1 Like

thank you for the heads-up announcement – its appreciated !!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.