Requesting VM installer script version 5.99

Hey guys, I can’t live with version 6 at this moment. I think it’s best if I give it some time.

I don’t want to look elsewhere for a web control panel, I’ve grown much love for Webmin/Virtualmin.

I’m sure someone out there who hasn’t updated his server, please share your copy of the installer script that server has executed when you first installed VM :slight_smile:

Thanks in advance guys.

It’s available in the repos:

But, please report problems! Don’t just say “I can’t live with version 6”. What distro and version are you using, what errors do you get?

Generally having horrific problems with 6.0 2 identical systems down to the model of machine and network card Installed from same source .iso
System 1 Centos 7 Full Updates VM 5.99 Generally works as expected
System 2 Centos 7 Full Updates VM 6.0

After 4 installs on system 2 I figured I better turn to the people that know far more than I.
The only error I get during install is “The file system /home could not be remounted with quotas enabled you may need to reboot your system and or enable the disk quotas module”
Virtualmin starts as expected can add a domain lets call it once I add I can get a server response and with SSL error as expected for a blank domain with the index link displayed.

After reboot back into VM and apache don’t start, manual start inside VM, no longer same response from forbidden errors. On a whim tried to add wordpress and installer ran as expected after yum install unzip. Try to go to the WP installer finish up and browsers just want to download or open files no display. I have tried many scenarios between all the above mentioned steps and the constant thing seems to be everything breaks after reboot. Tried other various functions like adding SSL with no luck.

Have done full format the install 4 times to make sure I wasn’t really missing something. I am about to run it again with the 5.99 and see what happens as something in 6.0 don’t like me. Any ideas? Hints? Hammers?

out of order post deleted

Please don’t just keep reinstalling! Bring me the problems you find, when you find them, and I’ll fix them. I can’t fix ephemeral problems: “Something went wrong, so I started over five times, and then I deleted everything.” doesn’t give me any information I need to fix things.

And, you won’t actually have the full Virtualmin 6, if you install with You’ll have the Virtualmin virtual-server module version 6.0. But, about half of the new features in Virtualmin 6 are in the installer. If you don’t need those features (fail2ban, a default firewall, TLS and SFTP and chroot for ProFTPd by default, Jailkit installed by default, and a few other extra configuration enhancements), then the old installer is fine…but, I’d really like to find out what the problems people are having actually are, so I can fix them.

So, if I’m understanding you, you have not reinstalled one of your systems that was installed with the Virtualmin 6 installer, correct? And, the problem you had, so far:

  1. Apache not started on reboot. What does “systemctl status httpd” say? (specifically, I want the whole “Loaded:” line)
  2. unzip package not installed, by default. I’ll fix that.
  3. PHP apps not working, and instead downloading the content of the file. Which php execution mode do you have selected for the domain? And, what happens if you switch to another execution mode and then switch back?

Is that all?

You’re not upgrading to 6.0. You’re just getting the Virtualmin virtual-server module version 6.0. Downgrading to module version 5.99 won’t fix any of the problems you mentioned above. Those are installer or configuration issues.

System 1 Centos 7 with vm 5.99 installed about 3 weeks ago with VM 5.99 runs as expected

System 2 with 6.0 I have installed a couple times thinking it was because initially DHCP without proper FQDN was set with no active connect during install. The last 2 installs I have working images of them if you care to look.
I am away from office until Sunday or Monday and am happy to give you remote access if you like Major problem after reboot things go to sh**. The 3 points are accurate. I have never had a 100% functional install on 6.0 I am happy to provide logs or screen shots anything you like to help. Little new to the Virtualmin world so I might need a little extra hand holding to get you what you need. 4th one on the 90% is no http to https redirect by default. This is the one I installed with the 5 script. So may just want to count that one as not counting. Happy to do anything for the betterment of your great product / service.

“4th one on the 90% is no http to https redirect by default.”

I can’t think of anywhere that http to https redirect is supposed to be happening by default; that’s something that needs to be turned on, no matter which version of the installer you’ve used. It’s something I’ve noticed people asking for lately, so it’s probably something we’ll make a little easier in the GUI (there is already a redirect UI, but it seems like people really want just, like, a button that says “Redirect http to https”, which doesn’t exist in the GUI currently, I don’t think…unless Jamie has added it fairly recently). Can you be more specific about what you expect to happen in this regard?

I found a case where Apache wouldn’t be started on reboot, if nginx was installed prior to installation; it comes sooner in the boot process, and so it would prevent Apache from starting. But, that shouldn’t be a common occurrence (if someone installed with the LEMP bundle and then changed their mind, for whatever reason, and switched to the default LAMP stack, it’d probably happen). I’ll update the --uninstall mode to remove nginx packages to maybe alleviate that.

Does that apply to your situation? Even if so, I’d still like to see the systemctl status httpd when you get a chance. That’ll tell me if the service is even trying to start on boot.

no nginx installed, just the basic Cent7 that is why I did it at least the first couple times to follow my original set up notes from System1 on System 2. On System 1 (5.99) when I added SSL Apache it would redirect all http on that virtualmin server (domain) to https. As I said before I would be thrilled to give you any access to either one or both machines so you can poke around. I also noticed on machine 2 that when WP was added I did not get a email notify. I will be back in the city tomorrow and will post my findings. I will consider my 90% (latest) suspect because of using the old script. I will restore my “pure” 6.0 install and call it the point in which to move forward with. I am not opposed to doing a clean start install if you release a new script. I have sort got the Cent install down :slight_smile: I am not looking at it as 4-5 failed experiences I am looking at it as 4-5 learning and documentation experiences as I am trying to move away from Windows hosting for webs and move into a centralized management platform the VM Pro offers on Cent. We have deployed several machines for clients with cent 7 and VM over the last year and really like the ease of use / deployment /management. Again full access if you need it. Help me help you!
Thanks again

Here is a screen shot after running systemctl status httpd

removed image link pasted text below

[root@billion ~]# systemctl status httpd -l
● httpd.service - The Apache HTTP Server
Loaded: loaded (/usr/lib/systemd/system/httpd.service; disabled; vendor preset: disabled)
Active: inactive (dead)
Docs: man:httpd(8)

Aug 21 03:27:02 systemd[1]: Unit httpd.service cannot be reloaded because it is inactive.
Aug 21 03:27:07 billion.
.com systemd[1]: Unit httpd.service cannot be reloaded because it is inactive.
Aug 21 03:27:07 billion.*****.com systemd[1]: Unit httpd.service cannot be reloaded because it is inactive.

So, that indicated Apache just isn’t enabled on boot. I found where that can happen in the virtualmin-config package due to misdetection of systemd vs initscripts vs upstart, and am rolling a fix for it over the next hour or two (it’s got some other fixes and enhancements that I’m testing).

You can fix it manually just by enabling it:

# systemctl enable apache2

And, of course, starting it:

# systemctl start apache2

Back on the out of the box 6.0 script install. So with Apache no start out of the way I get the PHP handler problem if I try to open any php file via a web browser. I assume there is a setting to change the php handler. Cant seem to find it.

Comment out everything in /etc/httpd/conf.d/php.conf

i.e., put a # in front of every line in that file that doesn’t already have a # in front of it, and then restart httpd with:

# systemctl restart httpd

I’ve got a fix for this checked in, but it hasn’t rolled out to the repos yet; it won’t automatically be applied to already installed systems, anyway, though, so you should go ahead and do it manually. I’m considering removing mod_php from the default installation right now, which would also fix this problem (this configuration file comes with mod_php and sets up Apache-wide configuration options for PHP, but they’re wrong for a virtual hosting system like Virtualmin where every virtual host can have a custom PHP configuration). I’m running a poll about that now…if I don’t hear from anyone who’ll be harmed by removal of mod_php I’m just gonna rip it out so we don’t have to deal with configuration files that fight against our desired outcomes. :wink: