Requesting a certificate for, * from Let's Encrypt .. .. request failed

So here is my error…

Requesting a certificate for, * from Let’s Encrypt …
… request failed : Web-based validation failed : Wildcard hostname * can only be validated in DNS mode

I note the following on github…

I had a quick look, and actually this isn’t totally trivial - wildcard certs can only be requested with the ACMEv2 protocol, and also only via DNS validation(which Webmin does support, but which won’t work for users that don’t host their own DNS).

which is unfortunately me (ie i dont host my own nameservers)

So, how do i get a virtual server ssl certificate to share with a subserver? (my webmin/virtualmin system is currently not doing this)

I then tried the following from same post in github…
For anyone else who finds this, the certbot that comes with Debian 9 is not quite up to the task, and requires the backports version of certbot.

Debian 9 Instructions for getting wildcard working with virtualmin
For stretch add this line
deb stretch-backports main
to your sources.list.

apt update
apt-get install python-certbot-apache -t stretch-backports

The in virtualmin, add the * wildcard to the lets encrypt area. Don’t forget to include your base domain if needed!

Thanks Virtualmin team.

I still get the same error.