Removing clamd,spamassasin & all other mail related services

I am attempting to remove all mail services from Virtualmin specifically clamd which takes up 5x the memory of any other process I have running.

I have attempted to uncheck everything from System Settings > Features & Plugins and then go into Webmin > Disable Now & At Boot for these services but they always start on a server restart.

Is there any way to totally remove these and have them actually stay gone?

If you go into Webmin -> System -> Bootup and Shutdown, you should be able to stop the process, then set it to not start on bootup.

If that’s not working – which distro version and Webmin version are you using?


Sorry, where I was selecting Disable Now and On Boot was in the Webmin > System > Bootup & Shutdown options. Oddly enough all the services listed say No under ‘At Boot?’ this was like that before I made any changes. When I disable them it does shutdown the services but they always restart on a server restart even though I specifically mark them to disable on boot as well.

I am running:

Ubuntu 10.04 64bit

Webmin 1.534

Virtualmin 3.84 GPL

This is off of a fresh Ubuntu 10.04 install and installing virtualmin using the script. I haven’t added any virtual servers yet since I am trying to disable email services before I do this.

I kind of recall a bug in Webmin’s Ubuntu support that could cause that… a new version should be out shortly (versoin 1.540). If that doesn’t fix the problem, you’re probably seeing a bug.

So, install 1.540 when it comes out, try it out… and if it doesn’t work, file a bug report using the Support link above.