Remove Virtual Server but not delete instance EC2

Added an EC2 instance already exists to my new server Cloudmin. But he did not recognize the virtualmin installed it.

I would like to remove this server cloudmin to add again to recognize the virtualmin.

How to do this procedure is the only option I have is to delete the instance.

Thanks

Howdy,

Well, removing it won’t likely change whether or not Virtualmin is recognized… if it doesn’t see Virtualmin, that may mean it’s unable to access port 10000 on that server for some reason.

You could always try telneting to port 10000 on that other server, from your Cloudmin instance, to see if that works.

You could also click “Refresh Status Fully” to make it retry it’s attempt to see Virtualmin.

However, if you ever do wish to remove a system from Cloudmin, you could go into “List Managed Systems”, and use the “De-Register” button there to remove it from Cloudmin. That won’t affect the actual server, that just removes it from Cloudmin.

-Eric

I’m trying to add again but does not recognize the Virtualmin.

This giving the following error when connecting to SSH.

Checking SSH login ..
.. SSH connection failed : (The authenticity of host '177.71.179.154 (177.71.179.154)' can't be established. RSA key fingerprint is 3e:2f:a8:c9:f8:37:b7:4e:04:73:23:61:bb:0b:19:73. )? Warning: Permanently added '177.71.179.154' (RSA) to the list of known hosts. grep: /etc/webmin/miniserv.conf: Permission denied grep: /etc/webmin/miniserv.conf: Permission denied grep: /etc/webmin/miniserv.conf: Permission denied uid=1000(ubuntu) gid=1000(ubuntu) groups=4(adm),20(dialout),24(cdrom),25(floppy),29(audio),30(dip),44(video),46(plugdev),110(admin),1000(ubuntu),1077(subversion) HOSTNAME server1.joosoftwares.com.br OK )

If I choose the option “Do not attempt SSH login” but it adds the server does not recognize the Virtualmin.

I imagine it might be some setting wrong in Virtualmin GPL I’m trying to connect.

Howdy,

It looks like you’re logging in as a non-root user.

Cloudmin would need to log in as a root user over SSH in order to have the correct permissions.

I know that Ubuntu systems don’t have a root user setup by default, but you could set a password for the root user on that server.

-Eric

If I login with User root happens the following error:

.. SSH connection failed : Login failed (The authenticity of host '177.71.179.154 (177.71.179.154)' can't be established. RSA key fingerprint is 3e:2f:a8:c9:f8:37:b7:4e:04:73:23:61:bb:0b:19:73. )? Warning: Permanently added '177.71.179.154' (RSA) to the list of known hosts. Permission denied (publickey). )

If I’m using SSH with password or EC2 Key

I had already set a password for the root User

Howdy,

It looks like it’s having trouble logging in as the root user at that server. Try that manually… log in over SSH from your Cloudmin server to that host as root. What happens when you try that?

If you’re unable to login manually, Cloudmin won’t be able to do it either.

-Eric

As I had already commented on the EC2 instance User root is not used for SSH access. Always use another User for connection.

I changed the default access EC2 to allow root access and cloudmin worked.

He returned the following message:

Checking SSH login ..
.. Logged in OK.

Checking Webmin login ..
.. Logged in OK.

Fetching current status ..
.. status successfully retrieved (Virtualmin - Config errors found)

Checking Virtualmin configuration ..
.. errors found: 0

which means that message “Config errors found”?

It is a suggestion of improvement for use with EC2 to not require root login via ssh.

Great, I’m glad SSH is working!

Now, as for the other error you’re seeing there –

I believe that’s a Virtualmin error on the remote server.

If you log into Virtualmin on that server, go into System Settings, and click “Re-Check Config”. That will show you the error it’s seeing.

-Eric