Remote API returns 526

OS type and version: Ubuntu 20.04.3
Webmin version: 1.973
Virtualmin version: 6.16
Related products version: N/A

I am trying to use the following default example php script that I got from the docs to create a new virtual server:

<?php
$result = shell_exec("wget -O - --quiet --http-user=root --http-passwd=somePassword123 --no-check-certificate 'https://example.com:10000/virtual-server/remote.cgi?program=create-domain&domain=exampleDomain.com&pass=someDomainPassword123&unix&dir&webmin&dns&web&mysql&mysql-pass=someDBpassword123'");

echo $result;
?>

But ended up getting the following:

The --web option cannot be used unless the feature is enabled in the module configuration

How can I enable the website feature when the virtual server isn’t even created yet in Virtualmin?

Ok I figured it out. If you are using Nginx, you need to use virtualmin-nginx instead of web.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.