Remote API Executing Twice

Remote API Issue

  1. When using remote API to create server, it is auto executing two times, at first, it’s creating the server then it is just reloading and this time giving error that this domain is already created, ho to stop this?

  2. I am using a PHP script to proceed further if the API response is a success but since it’s not stopping and just reloading the whole stript, it is never giving “success”, it’s always giving an “error”, in spite creating the sever at the first attempt.

This is really annoying issue, anyone facing such an issue?

Any solution guys?

If this is solved, no other issue faced with the remote API, other things are great.

My server language is PHP.

I am using this command which is 100% correct as checked

‘wget -O - --quiet --http-user=root --http-passwd=myPassword --no-check-certificate https://myIP:10000/virtual-server/remote.cgi?program=create-domain&domain=text.com&user=newusername&pass=newpassword&default-features&json=1

I ran this in the browser, substituting the URL of a Virtualmin server for myIP and it reported success, created the virtual server bound to domain text.com, as was expected.

System hostname vps03.indiax.com (127.0.0.1) Operating system CentOS Linux 7.8.2003
Webmin version 1.942 Usermin version 1.791
Virtualmin version 6.09 Authentic theme version 19.46

Hope this helps.

‘wget -O - --quiet --http-user=root --http-passwd=myPassword --no-check-certificate https://myIP:10000/virtual-server/remote.cgi?program=create-domain&domain=text.com&user=newusername&pass=newpassword&default-features&json=1’

I am trying this using PHP it’s executing twice
Can you please try using PHP exec() function

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.