Relay access denied; Troubleshooting Postfix config

Greetings, can anyone help a newbie troubleshooting email server configuration?

Been researching for days but the lack of know-how makes it hard to interpret probable causes and solutions…

I get “Relay access denied” when sending to external emails.

The log:

Oct 23 00:20:05 server postfix/smtpd[10382]: connect from xxx-xxx-xxx-xxx.cpe.netcabo.pt[xxx.
xxx.xxx.xxx]
Oct 23 00:20:05 server postfix/smtpd[10382]: NOQUEUE: reject: RCPT from xxx-xxx-xxx-xxx.cpe.netcabo.pt[xxx.xxx.xxx.xxx]: 554 5.7.1 my@gmail.com: Relay access denied; from=my@server.com to=my@gmail.com proto=ESMTP helo=<[192.168.0.13]>
Oct 23 00:20:14 server postfix/smtpd[10382]: disconnect from xxx-xxx-xxx-xxx.cpe.netcabo.pt[xxx.xxx.xxx.xxx]

The postconf -n result:

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
allow_percent_hack = no
broken_sasl_auth_clients = yes
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
data_directory = /var/lib/postfix
debug_peer_level = 2
home_mailbox = Maildir/
html_directory = no
inet_protocols = all
mailbox_command = /usr/bin/procmail-wrapper -o -a $DOMAIN -d $LOGNAME
mailbox_size_limit = 0
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man
milter_default_action = accept
milter_protocol = 2
mydestination = $myhostname, localhost.$mydomain, localhost, server.gbelle.com
newaliases_path = /usr/bin/newaliases.postfix
non_smtpd_milters = inet:localhost:8891
readme_directory = /usr/share/doc/postfix-2.6.6/README_FILES
sample_directory = /usr/share/doc/postfix-2.6.6/samples
sender_bcc_maps = hash:/etc/postfix/bcc
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
smtpd_milters = inet:localhost:8891
smtpd_recipient_restrictions = permit_mynetworks permit_sasl_authenticated reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_authenticated_header = yes
smtpd_tls_auth_only = yes
unknown_local_recipient_reject_code = 550
virtual_alias_maps = hash:/etc/postfix/virtual

Howdy,

A common cause of what you’re describing is when the email client isn’t configured to authenticate when sending outgoing email, which several clients don’t do by default.

My suggestion is to review the mail client settings, and verify that it’s configured to authenticate when sending email.

-Eric