Redirect Errors in Usermin via Apache proxy

I need Usermin to be accessable via a standard port. ( I tried applying the instructions at to setup a proxy for Usermin, but was unable to get Apache configured properly by hand. Instead, I used the “Proxy Paths” module in Virtualmin to set up the proxy. This kind of works, but I have several issues that I don’t think are related to the way that the proxy was setup. After logging in, Usermin tries to redirect me to the proxied url (http://localhost:20000) and causes an error. If I start back at, I am logged in and see the Inbox. I found this behavior also occurs when composing, deleting, marking read/unread, forwarding mail, using the"Change IMAP login" link, changing Spamassassin settings, and maybe other actions. There is also no login link.

It is possible to run Usermin proxied like this, and the ‘Proxy paths’ feature of Virtualmin is the easiest way to set it up - it actually adds the ProxyPass and ProxyPassReverse directives documented on that page you mentioned.

However, you also need to add the following lines to /etc/usermin/config , so that it knows it is running under a proxy URL :


Let me know if that works or not…

I didn’t explain myself very well, but /etc/usermin/config is where I put the config settings. What’s strange is I hadn’t tried logging in since I first posted this, but now I can’t. The only way I can login now is by removing the webprefix settings from the config file. Before I could log in, but I got the bad redirect behavior. I installed the Virtualmin update yesterday. Could that have affected this?

If you look at your Apache configuration file for the virtual server, what do the ProxyPass and ProxyPassReverse lines contain?

Also, I thought of another possible problem - sometimes proxying doesn’t work too well for Usermin in SSL mode (which is pointless anyway). So try turning off SSL in the Usermin Configuration mode, and make sure your proxy URL starts with http:// and not https://