Receive email with username.domain@domain.tld

I cannot find another post with this particular problem, so my apologies if I missed it.

I am running postfix 2.9.6-1~12.04.2 as my mail server under virtualmin 4.14 on Ubuntu 12.04.1. I also have an account with Blackberry that requires me to use my login account as my email account, ie blackberry.domain@domain.tld for blackberry@domain.tld. Blackberry wants to send a confirmation email address, but on doing so my server responds with:

postfix/smtpd[11099]: NOQUEUE: reject: RCPT from[]: 550 5.1.1 Recipient address rejected: User unknown in virtual alias table; proto=ESMTP helo=<>

I have primary address enabled, and if I try to send the same address a message from a valid email account, I still get the same address rejected message. This has never worked properly but I was not concerned about it until now. Any ideas?


Hmm, do another email accounts work properly on your server? Is it just an issue with this one account? Or are you having problems emailing all accounts?

Also, do you notice any problems if you go into System Settings -> Re-Check Config?


Hi Eric,

Thanks for helping!

email sent to works as expected, in fact all mail accounts work except the user.domain accounts which cannot receive mail in all configured domains. In thunderbird or webmail, I have to login with the user.domain username to collect mail, but that is all that user.domain can do.

When I run System Settings -> Re-Check Config, I get the following responses among all the rest:

BIND DNS server is installed, and the system is configured to use it.

Mail server Postfix is installed and configured.

Postfix can support per-domain outgoing IP addresses, but is not currently configured to do so. This can be setup in the Postfix Mailserver module.

SpamAssassin and Procmail are installed and configured for use.

…your system is ready for use by Virtualmin

I am not seeing any errors come up at all except for the bit about postfix not being configure for per-domain outgoing IP addresses, but since I have only one internet facing IP, this should be ok. Is this just a simple error in the postfix config?