Re-sending Welcome Email

Hi there,

Having a few issues with trying to re-send a welcome email… There’s no button for it anywhere, as I have looked… and after a lot of searching I’ve found that inside of there is a:

/usr/libexec/webmin/virtual-server/resend-email.pl --domain <domain>

After trying this, it gave me a:
Signup email is not enabled for this domain

I commented the last if block out just to see if I could force it to send mail, but still no dice.

Any advice as to what’s up? I don’t see any mail attempts even inside of /var/log/maillog… and I can send email fine from the box via webmail/telnet into smtp etc.

Running: Version 3.68.gpl

Thanks!
Elsdon

Howdy,

Do you have the signup email option enabled in the server templates?

If you go into System Settings -> Server templates -> Default Settings -> Mail for Domain, is "Email message to send upon server creation" set to "None", or is it using the message in the textarea below that?

If that’s set, and you’re still unable to re-send the signup email, that may mean when the Virtual Server was initially created, it was setup not to send a signup email.

If that’s the case, you may need to manually correct that. You can do that by going into /etc/webmin/virtual-server/domains, and editing the file that represents your Virtual Server – and set “nocreationmail” to “0”.
-Eric

Hi Eric,

There was the default one there before.

Seems to be gone now, weird… As in, deleted. Adding it back to try it again.

Thanks for the quick response. :smiley:

Hrm, unable to edit this post… But, after putting the welcome email back into the Default Settings, inside of:

/etc/webmin/virtual-server/domains/<id>

I couldn’t find any such key as ‘nocreationemail’ so I just added the:

‘nocreationemail=0’

to the bottom of the file… It works now, thanks!

Hi,

Related to this matter.

How do I change the from address that the server uses when it sends the welcome mail? I’ve googled my virtual socks off, but I cant find out how to do this.

At the moment it is sending from
webmin@
Which is understandably failing sender verify checks.

I look forward to hearing from you :slight_smile:

Howdy,

If you go into System Settings -> Module Config -> Actions upon user and server creation, you can change the setting "From: address for email sent by Virtualmin " to your preferred address.
-Eric

Hi Eric,

That is perfect, thank you very much.

Is there any way I can change the default one, so that nothing uses the webmin@ any more?

Thanks again,
Phil,

Hey Phil,

No problem!

Don’t forget that many of those field names are clickable in order to get additional help on the topic.

For example, clicking the text "From: address for email sent by Virtualmin " pops up a screen that mentions:

"Virtualmin sends email to users for a number of reasons, such as disk uage quota overage, bandwidth usage overage, account creation, etc. You may choose what address will be used in the From: field of these messages. This can be useful if you’d like for all replies to come to a support ticket system, for example. "

That is – changing what you did should effect the majority of the emails that Virtualmin sends out (it’s possible there’s an exception to that somewhere, but what that is isn’t coming to mind at the moment :wink:
-Eric

Hey Eric,

I did click that alright, and (using my noggin!) I went to my SSH session and tried:
virtualmin config_from_addr

But that failed, and I had such high hopes.

But if that has set it for the majority, which my subsequent testing seems to agree with, then I’m all good now anyway, and thank you ever so much for your great help and prompt replies :slight_smile:

Regards,

Phil,

Heh! I like the way you think. I’ve been bugging Jamie about making more things editable from the command line :slight_smile:

Yeah, that should set things for just about everything.

I seem to remember that there’s one in particular that isn’t affected by that, but I can’t for the life of me remember what it is :slight_smile:

However, if you run across one, it either is changeable somewhere else, or a bug, so let us know and we’ll figure it out :slight_smile:
-Eric

Hey Eric,

I have found an email with the from address set as ‘webmin@’

It is the security updates mail.

If you can tell me how I can go about updating that, as my VPS is constantly getting blocked as a spammer :slight_smile:

I look forward to hearing from you (or anyone that can help!)

Regards,

Phil,

You can change the from address in System Settings -> Server Templates -> Actions upon user and server creation -> “From: address for email sent by Virtualmin”.

However, if your email is being tagged as spam, most likely it’s due to incorrect settings on your server, your server’s IP being blacklisted , an issue with DNS, or something similar.

You might want to plug in your domain here and look for any errors:

http://www.intodns.com

You may also want to make sure your IP address doesn’t appear on a DNS RBL list:

http://www.anti-abuse.org/multi-rbl-check/

Hey Eric, (edit, put in Andrey first, heh)

Thank you very much for your reply, I have already changed the address in there, after Eric instructed me to do so, however, although almost all mails now go out with the correct From address ‘support@mydomain.com’. the security updates is still being sent with a from address of ‘webmin@’

Regards,
Phil,