Re-installed Virtualmin and...

…now I can’t get my website to load. The index.html in /var/www keeps loading. In Virtualmin, Website Options, Website documents sub-directory = public_html.

This is a fresh install. Why won’t my webpages load from public_html?

I appreciate all the great help I get here. Just wanted to mention that.

Howdy,

Was it just Virtualmin that was reinstalled, or was your entire server reinstalled?

Also, what Linux distro/version are you using?

-Eric

Hi andreychek:

I reinstalled a fresh server, Debian 7. The problem seems to be that, when I set up my website on a virtual server, Virtualmin wants to use 127.0.0.2 for my domain, when my actual IP is 167.88.120.164. And this was an issue because my website kept loading from /var/www/index.html (the one web page put in by installing the OS) instead of the public_html directory where my website resides. So, in messing around in Virtualmin --> Server Configuration --> Change IP Address and Server Configuration --> DNS Options, I was able to set my IP from 127.0.0.2 to the right one. My website loads now, andreychek. But what I don’t understand is why I had to manually do all of that. Had I not made those changes, I’d still be loading /var/www/index.html. Is this a configuration issue with Virtualmin? Virtualmin correctly identified my correct IP, but in creating a virtual server for my site to run off of, it put me on 127.0.0.2, a locally shared IP, and my website wldn’t load from public_html. Any ideas?

Howdy,

You may want to double-check some settings in System Settings -> Virtualmin Config -> Network Settings.

In there, verify that Network interface for virtual addresses, Default virtual server IPv4 address, and Default IP address for DNS records are all set to the correct values for your server.

-Eric

Hi andreychek:

Under System Settings -> Virtualmin Config -> Network Settings, everything looks good (now). Until I manually made changes to reflect my true IP address, it was set to 127.0.0.2. And I guess that’s my issue, andreychek: that I had to manually set my IP so my website would show from puiblic_html instead of Virtualmin doing that for me when I set my site up on the virtual server. There are no instructions on this website that explains anything like that. So I was basically shooting in the dark, trying to fix what shldn’t have been broken. Know what I mean?