Raspberry Pi 2 and Virtualmin

Do you plan to support for the Raspberry Pi ? For example, the system raspbian ? Will the new Raspberry Pi 2 is a sufficiently strong hardware to run on it Virtualmin ?


Following your best advice, I have removed Ubuntu 15.04 and downgraded to 14.04 LTS, in order to install Virtualmin on my R Pi2.

However, I still encounter an ambiguous error, along the lines of, 'Fatal error Occurred: Something went wrong…

Cannot continue installation.’

The script continues a little farther, until, ‘Installing dependencies using command: /usr/$les sas12-bin php-pear php5 php5-cgi libapache2-mod-php5 php5-mysql’. From there, it’s fatal errors, all the way.

I tried a part-manual install of procmail and scponly, as guided by another website but, this gets the clear error that ’ (amd64) does not match system (armhf). I’m using a RPi 2 and, can guess what’s occurring here.

Can you provide a workaround or an eta to resolve this issue or missing package library?

I see that they’ve been fielding this same question since 2008 and so, at 7 years and counting, I’m not going to hold my breath for a solution.

In fact, I’m not going to install virtualmin, and I’m pulling webmin, going back to the latest Ubuntu OS, and seeking an admin solution that supports the modern age.

As a user, I support tools that support me - and that ain’t virtualmin.


Sorry, we haven’t done any testing on the Raspberry Pi.

It may be possible to get it working with a manual installation, but I suspect the automated install wouldn’t work properly since there isn’t a repository for that architecture.



I’ve just installed webmin and virtualmin on my raspberry 2. It works like a charm (a bit slow, but it’s normal).

So I followed this tutorial : http://geekanddummy.com/how-to-raspberry-pi-tutorial-part-3-web-file-hosting-with-webmin-virtualmin/ and of course taking the latest version of webmin (and theme). For a moment I thought I was going to be stuck with the old theme, but I soon got the info message with an invitation to change to the new html5 theme (which is awesome !!!).

Thanks for the good work,


I installed Virtualmin on a Pi-3 the same way as in the link shared by @homzon. It works.
To have PHP7 working on your raspbian jessie, check https://www.stewright.me/2016/03/turn-raspberry-pi-3-php-7-powered-web-server/
Then go through lengths scavenging php modules, enabling apache mods and such… (the things that come automatically when using the virtualmin install.sh)
Tedious but you will get it all to work. (check your applications requirements for the modules)…

I do have a nextcloud instance running it requires ssl. It also requires HSTS enabled. thus had to ad this:

<VirtualHost *:443>
ServerName cloud.owncloud.com

Header always set Strict-Transport-Security “max-age=15768000; includeSubDomains; preload”

to the vhosts file. I could not find a way to add this to the server template. Anyone?

(Owncloud also requires a newer version of libgd3, libpng16-16 and libwebp6. You can get that from https://packages.debian.org/nl/sid/libgd3. It really works)


Now there is only one issue. It will not update. As there is no repository set.
As virtualmin is installed as webmin module, I assume I need this in my sources.

deb http://software.virtualmin.com/gpl/wbm (dist)

But what do I put at (dist)? Anyone?

No dist, no apt, the wbm repo is for Webmin module packages (.wbm, which is a tarball with some meta data in a module.info file). It is not an apt repo, at all. You need to setup module updates within Webmin. It’s been many years since I’ve used that feature, so I don’t know exactly how to set it up! Something in Webmin->Webmin->Modules, probably?

Thanks I found it, only think is that the files in software.virtualmin.com/gpl/wbm are .deb.gz
When I webmin-webminconfig->upgrade webmin->Update Modules->Update from others sources: http://software.virtualmin.com/gpl/wbm and the press update modules, I get:

Failed to update modules : Invalid module updates source file

Any thoughts?