Ran 3 Package Updates in Webmin and Now Apache wont run?

OS type and version Ubuntu 20.04.4 LTS
Webmin version 1.991

Based on the logs I ran the 3 package recommendations. Rebooted server and now Apache wont run.

Any suggestions? Thank you in advance!

Reading package lists…
Building dependency tree…
Reading state information…
The following packages will be upgraded:
libssl1.1 networkd-dispatcher openssl
3 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
[master 1df64ace] saving uncommitted changes in /etc prior to apt run
3 files changed, 8 insertions(+), 8 deletions(-)
Preconfiguring packages …
Need to get 0 B/1957 kB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database …
(Reading database … 5%
(Reading database … 10%
(Reading database … 15%
(Reading database … 20%
(Reading database … 25%
(Reading database … 30%
(Reading database … 35%
(Reading database … 40%
(Reading database … 45%
(Reading database … 50%
(Reading database … 55%
(Reading database … 60%
(Reading database … 65%
(Reading database … 70%
(Reading database … 75%
(Reading database … 80%
(Reading database … 85%
(Reading database … 90%
(Reading database … 95%
(Reading database … 100%
(Reading database … 239041 files and directories currently installed.)
Preparing to unpack …/libssl1.1_1.1.1f-1ubuntu2.13_amd64.deb …
Unpacking libssl1.1:amd64 (1.1.1f-1ubuntu2.13) over (1.1.1f-1ubuntu2.12) …
Preparing to unpack …/networkd-dispatcher_2.1-2~ubuntu20.04.3_all.deb …
Unpacking networkd-dispatcher (2.1-2~ubuntu20.04.3) over (2.1-2~ubuntu20.04.2) …
Preparing to unpack …/openssl_1.1.1f-1ubuntu2.13_amd64.deb …
Unpacking openssl (1.1.1f-1ubuntu2.13) over (1.1.1f-1ubuntu2.12) …
Setting up networkd-dispatcher (2.1-2~ubuntu20.04.3) …
Setting up libssl1.1:amd64 (1.1.1f-1ubuntu2.13) …
Setting up openssl (1.1.1f-1ubuntu2.13) …
Processing triggers for man-db (2.9.1-1) …
Processing triggers for libc-bin (2.31-0ubun

Did you disable mod_php after the virtual-server module update?

Apparently there’s a bug in that that leaves behind mod_php directives in the Apache configuration. We’re working on an update. But, if that’s what you did, the fix is to remove all php_* directives from the Apache virtual hosts (in /etc/apache2/sites-available/*.conf on Ubuntu).

If that isn’t what happened in your case, we need to see the Apache error log when you try to start Apache and the output of apachectl configtest


Yes I did disable the mod_php as recommended in Webmin.

OK, so that’s the problem (never install mod_php!). Easy fix. Just remove every php_ directive and restart apache2 service.

Okay so go through every virtual host .conf file in that directory and remove the php_ values such as php_admin_value engine Off, php_value memory_limit 32M
php_value suhosin.session.encrypt Off, etc and then try to run Apache2?

Thank you

Thank you very much Joe. This solved it! Not sure how mod_php got on there. Could it have been brought over from when i migrated an older CentOS CPanel server?

Thanks again you are the best!

No (unless you mean Virtualmin was installed on a server that original had cPanel on it, but I don’t think that’d be easy to do).

You probably installed php (or phpVERSION-php if you installed additional PHP versions), which is the package that contains mod_php. Very old virtualmin systems would have also gotten mod_php, but for CentOS it’s been about four years since we removed it from the default installation.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.