Quotas problem

I am using Webmin ans Virtualmin and if I “re-check” the Virtualmin configuration I get this error: The module could not find the mount point for your home directories filesystem /home. Quotas editing has been disabled.

My /etc/mtab:

/dev/vzfs / reiserfs rw,usrquota,grpquota 0 0 proc /proc proc rw 0 0 sysfs /sys sysfs rw 0 0 tmpfs /lib/init/rw tmpfs rw,nosuid 0 0 tmpfs /dev/shm tmpfs rw,nosuid,nodev 0 0 devpts /dev/pts devpts rw,nosuid,noexec 0 0

My /etc/fstab:

proc /proc proc defaults 0 0 none /dev/pts devpts rw 0 0

I have tried different things but nothing helped. Can someone help me?


I vaguely that quotas may not work while on OpenVZ, so that message you’re seeing is just informative… unless it’s telling you that Virtualmin isn’t ready for use.

However, I believe it’s just saying that you won’t have the ability to set quotas.

If you want to see if quotas might work, you could try putting your root filesystem into your /etc/fstab file, which should make that Virtualmin warning go away.

You could add new a line like this to your /etc/fstab file:

/dev/vzfs / reiserfs rw,usrquota,grpquota 0 0

After you do that, try clicking System Settings -> Re-Check Configuration to see if the warning goes away.


Do I have to restart the server after that?

EDIT: no :slight_smile: The quotas work now