Quotas gone

I recently upgraded from CentOS 5.1 to 5.2 (along with a bunch of other stuff) through yum and after doing so ran the Virtualmin/System Settings/Re-Check Config and got:

Quotas are not enabled on the filesystem / which contains home directories under /home and email files under /home. Quota editing has been disabled

Since I am the only user on the server and all the virtual hosts are mine and not customers I don’t care so much about quotas but will the fact that they were on with quotas set for email accounts and now they are off cause any issues with Virtualmin and any functionality?

Should I just turn quotas back on?

If so how do I do that?

Is it as simple as entering the command quotaon in a shell? If so does it need options?

Will I then have to go an reset all my mail account quotas?

What other functions are affected by quotas?

In theory, system quotas are enabled on bootup from within rc.sysinit if the command "/sbin/quotaon" exists.

So I suppose I’m wondering what the output of these commands are:

  1. /sbin/quotaon

  2. quota -v

  3. mount

That should help troubleshoot a few things… thanks,
-Eric

Oops, I didn’t mean for you to run “/sbin/quotaon” in #1 above (it won’t hurt, it’ll just show a usage message), I meant to see if it existed, like this:

ls -l /sbin/quotaon

If you don’t need’em, don’t waste resources on them. (Resource usage for quotas is minimal, but they can also cause other quirky behavior in some circumstances, so adding it up, if you don’t need’em then you don’t want’em.)

And, no. Leaving them disabled won’t hurt anything. Quotas are absolutely optional.

Eric - Thanks for helping! Yup it’s there :slight_smile:

Joe - That info helps :slight_smile:

I will leave quotas off with an unbridled sense of abandon :slight_smile: