quota problem [SOLVED]

hello all, sorry for my english, i’m french,

so, i’m trying to install virtualmin on a clean debian lenny by using this process:

apt-get update

apt-get upgrade

vi /etc/apt/sources.list

adding this :
deb http://software.virtualmin.com/gpl/debian/ virtualmin-lenny main
deb http://software.virtualmin.com/gpl/debian/ virtualmin-universal main

apt-get update

wget http://software.virtualmin.com/gpl/scripts/install.sh

chmod +x install.sh


install ok, i can access to virtualmin

BUT when I try to create a new virtual server, virtualmin tell me that :

setquota: Mountpoint (or device) /home not found or has no quota enabled. setquota: Not all specified mountpoints are using quota.

my fstab is :

/dev/sda1 / ext4 errors=remount-ro 0 1
/dev/sda2 /home ext4 grpquota,usrquota,rw 0 2
/dev/sda3 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs defaults 0 0

and quotaon /home
tell me:
quotaon: Mountpoint (or device) /home not found or has no quota enabled.

Have you any idea to solve this problem?

Thank you so much!


It was the file system ext4 that was the problem.

Reinstall with ext3 solve my problem

So thats the only fix? ext3?

Not necessarily… I’m using ext4 on my /home partition too, and it works all okay. I’ll post more in your other thread. :slight_smile:

The problem has to do with the quota files. You can do “quotaoff -a && quotacheck -avugm && quotaon -a” and it should fix the quota problem. Have posted the same at http://nitinsharma.info/?p=1297