Question about creating FTP users


Got a question about creating FTP users well 2 questions. I’ve created a virtual server added a domain and stuff like that the website works like a charm. But got the following “problems”


I want to give FTP users access to a folder in the root of the website. This works when i use dir’s without spaces like


but when i try Files/something/here something

It gives an error that the folder does not excist. I know with htaccess you have to use \ for spaces and that works. But how can i make sure the server knows the folder is there with spaces


When i create a new user it adds a .domain behind the name is there anyway to remove this and make it so that they can login by username only (for the FTP) they won’t be getting an email adres or anything like that

Thank you!

Quick reply, I’m not at my PC:

First, does it work when you put the whole path in quotes? Otherwise it might be a Virtualmin bug. Need to test this myself.

Second, you can change that behavior in the Virtualmin options, look for the setting “add domain to usernames, always, never, only to avoid a clash”.


Thanks for your reply.

First: Okay tried putting it with quotes that does not work. Tried it with %20 but that also does not work. i’m getting a bit clueless :slight_smile: I need to create 85 accounts because of a migration from a windows server to linux with virtualmin :slight_smile: but the old content contains lot’s of root folders for users with a space it in.


Found the option and it has always and only avoid a clash. Choose the last one because that will never happen :slight_smile:

Thanks for the help so far!

I’ve asked Jamie for some input regarding the issue with spaces, let’s see what he says :slight_smile:


Okay thank you

I’ve tried putting it in “” and escaping the space with \ but nothing seems to work. It seemds like a bug as far as I can tell :slight_smile:

thank you for asking.

I can confirm the problem when trying to use a path with spaces in “Website FTP access” user home directories. Looks very much like a bug.

Although I personally try to avoid paths with spaces in them whenever I can, for exactly the reason seen here. :slight_smile:

You shouldn’t need to use quotes or backslash to have a path with a space in it - however, due to an over-zealous check in Virtualmin this isn’t allowed when creating a website FTP access user :frowning:

I will fix this in the next release though.


Thank you for answering and for fixing the issue in the next release.